6 Replies Latest reply: Aug 7, 2017 3:58 AM by Jasper Bom RSS

    Lost connection to server, reconnecting

    Jasper Bom

      Hi guys,

       

      I am lost, I am having problems with losing connection to the server while having a document open via the accesspoint. This is always happening around 4-5 minutes. I am not able to pinpoint it exactly. Of course I have searched the internet in hope of finding a solution but alas..

       

      QlikView server version 12.10.20400.0(IIS), office 365 SSO.

      It is happening on any browser ( chrome, IE, Edge, Firefox)

      any location (IP)

      even from local host (via formlogin)

      Small and big documents.

      We have traced it via chrome network log, nothing shows that a connection has been lost. I click on something after 4.5 minutes and it goes through this:

      xQeMExh.png

      output in events log.

       

      20170703T165925.000+0200 20170705T092503.000+0200 4 700 Information Ticket created: Ticket (9ACD9F0BDB1453121032C70DC7F1289A0D757E0C) for <USER>.
      20170703T165925.000+0200 20170705T092503.000+0200 4 700 Information Ticket Lookup: Ticket 9ACD9F0BDB1453121032C70DC7F1289A0D757E0C was found.
      20170703T165925.000+0200 20170705T092503.000+0200 4 700 Information Server: Document Load: Beginning open of document
      20170703T165925.000+0200 20170705T092503.000+0200 4 700 Information System: Document Load - ODE1: Document <LOCATION>, AuthenLev(1). Authuser()
      20170703T165925.000+0200 20170705T092504.000+0200 4 700 Information System: Server - UpdateSharedFile: updating DONE for document <DOCUMENT LOCATION>
      20170703T165925.000+0200 20170705T092504.000+0200 4 100 Notice CAL usage: Using CAL of type "Named User" for user "<USER>". Named user cals in use: 2
      20170703T165925.000+0200 20170705T092509.000+0200 4 700 Information System: Server - UpdateSharedFile: updating DONE for document <DOCUMENT>
      

       

      I have added

      <system.web>
           <httpRuntime executionTimeout="900" />
           <sessionState timeout="20"></sessionState>
      </system.web>
      

      to the web.config

       

      in opendoc.htm of QlikViewAjax I added a constant ping of 1 minute

       

      in config.xml

      <QvsTimeout>7200</QvsTimeout>

      <SessionCookieTimeOut>7200</SessionCookieTimeOut>

      <ClearCachePeriod>7200</ClearCachePeriod>

      <StatusRecheckInterval>7200</StatusRecheckInterval>

      <HighlightThresholdMinutes>7200</HighlightThresholdMinutes>


      Document timeout is 60 minutes

      Allow only one copy of document in memory is turned off..

      Possible session timeout is unlimited

      maximum total session time is unlimited


      TCP and HTTP timeout has been set to 15 minutes instead of 4 minutes. (azure)


      IIS timeout has been set to 20 minutes.



      I have no clue were to look next. Does anyone has an idea, if any of the text is above or you need more information please ask, help me qlikview forum, you are my only hope.