4 Replies Latest reply: Oct 30, 2013 2:35 PM by Chris Corbin RSS

    Active Directory Groups

      Hello,

       

      Sorry if this is a dumb question (yes, they do exist!), but I have only a working knowledge of AD and I am still new to QV administration.  I am setting up a publishing job for a QVW, and I am on the Source Documents > Distribute > Manually section of QMC and I am setting to whom I will distribute my application.

       

      I choose "Named Users" and I want to add in a new AD security group. from a separate OU I have just for QV security and DL groups.  I created a group about 30 minutes ago, and when I search for users/groups to add when choosing to whom I want to distribute, I still am not seeing this new group.  This is the only group I have created today, and I see all other groups. 

       

      I have asked my networking team in the past, and I am always told it takes "15 minutes or so" for changes to AD to replicate throughout the network.  However, every time I add a new group it takes hours it seems before I can see it in QMC.

       

      Is there anything I should be doing with QMC to refresh AD?  Or should I be going back to my network team and asking them why it is taking so long?

       

      Thanks,

      Chris

        • Re: Active Directory Groups

          Hi Chris,

           

          I don't believe the groups you define within QlikView have any relationship to those in AD. QlikView reads from AD but,  doesn't write to AD. This hopefully explains why you don't see changes in AD (QlikView hasn't made any changes) . If you wish to define groups within AD, create them within AD and QlikView will use them. You may need to wait for 15 while AD replicates/refreshes changes made.

           

          Hope this answers your question?

           

          Thanks Steve

            • Re: Active Directory Groups

              Hi Steve,

               

              Sorry if my question is not clear.  I have created the groups in AD, I am trying to use them in QV but I am not seeing them as options.

               

              I have heard of this 15 min wait before, but it has been hours at this point and I still can't see the new group I created in AD this morning.

               

              Thanks,

              Chris

                • Re: Active Directory Groups

                  I see. You may find that IT have setup replication to take place out of hours or overnight. They can force replication to take place. It's AD related, so unfortunately out of QlikView's control.  Try using a wildcard search in users (under User Management tab) to see whether you can locate the groups within QMC, if not, you many need to allow time for overnight replication to take place.

                   

                  Thanks Steve

                    • Re: Active Directory Groups

                      Hi Steve,

                       

                      I figured out what the issue was, it was with the default value for the Activity Directory Directory Service Path, found in System > Setup > DSC > General.

                       

                      This had defaulted it seems to LDAP://[domain].com, and when I updated this to use a specific AD server it is replicating in the expected 10-15 minutes.

                       

                      Chris