Qlik Community

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

cancel
Showing results for 
Search instead for 
Did you mean: 
bbergstrom
Partner
Partner

Area Layer in Map for State (April 2018)

I am trying to create an area layer in a map based on the state code but it is showing CA in Ontario and other states are appearing all over the globe.  This is with the April 2018 release.  I tried the Zip code as well but that was showing a New Mexico zip in France.

1 Solution

Accepted Solutions
bbergstrom
Partner
Partner
Author

Found a solution for more than one country.  I added the country code to the data and using a MaxString(Country) in the Country field did the trick.

Bottom line was for this to work I needed the state listed as the name and the country code.  This is now working for the US and Canada.

View solution in original post

6 Replies
undergrinder
Specialist II
Specialist II

Hi Brian,

try config the map "scope for location" settings (country, administrative levels etc.).

The best solution is to have a coordinates to borders of your area layer.

G.

bbergstrom
Partner
Partner
Author

That seemed to work with a small data set but I am trying to use the State code (IL = Illinois) and that does not appear to be supported per:

https://help.qlik.com/en-US/sense/April2018/Subsystems/Hub/Content/Visualizations/Map/map-properties...

undergrinder
Specialist II
Specialist II

did any warning appear in edit mode on map? Like IL not found etc?

bbergstrom
Partner
Partner
Author

I have not yet tried with a full data set yet but will report back when I do.

bbergstrom
Partner
Partner
Author

Okay, using the full data set is placing some states in other countries (MT in Brazil for instance).  I set the location type to Administrative area (Level 1) and I can see the Country field but it appears to only allow one country.  Is there a way to set this to US and Canada?

bbergstrom
Partner
Partner
Author

Found a solution for more than one country.  I added the country code to the data and using a MaxString(Country) in the Country field did the trick.

Bottom line was for this to work I needed the state listed as the name and the country code.  This is now working for the US and Canada.