Qlik Community

Ask a Question

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
enmanuelHP
Contributor
Contributor

Autonumber problem, synth key generated

Greetings to all! I need to see a ligth to resolve an issue in Qlik Sense. I've created one composite key with the intention of relate tables with the same columns, but the problem is that Qlik Sense throws synth keys at the end of the load.

 

Example of the script:

[Company]:

Load:

C_Company_Id ,

C_Branch_ID,

C_Name,

AutoNumber(C_Company_Id &'-'&C_Branch_ID) as RelCompBranch;

... (SQL)

[BranchOffice]:

Load:

B_Company_Id ,

B_Branch_ID,

B_Name,

AutoNumber(E_Company_Id &'-'&E_Branch_ID) as RelCompBranch;

... (SQL)

[Item]:

Load:

I_Company_Id ,

I_Branch_ID,

I_Name,

AutoNumber(I_Company_Id &'-'&I_Branch_ID) as RelCompBranch;

... (SQL)

 

I've supposed that the problem was the name of the relationship (RelCompBranch) but when I changed the name the results of data were not consistent to the expected... I need to resolve this issue... Thanks in advance!

4 Replies
dwforest
Specialist II
Specialist II

After creating the key, remove the fields from all but one table
vikasmahajan

After script finish add this lines

drop fields C_Company_Id ,C_Branch_ID,E_Company_Id ,E_Branch_ID,I_Company_Id ,I_Branch_ID

 

Hope this will resolve issue.

 

Vikas

enmanuelHP
Contributor
Contributor
Author

Thanks for the suggestion... I wrote the DROP FIELDS at the end of the load but the result is the same, the synth keys continue Smiley Sad 

vikasmahajan

Can you attach your demo application ?