Skip to main content

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
siddharthsoam
Partner - Creator II
Partner - Creator II

Binary load qvw file with section access

Hi Team,

Hope you are doing well !!

I am unable to binary load qvw file with section access. I am receiving a general error. Tried to binary load after commenting the section access , worked fine.

I have admin access of the qvw file. 

Found similar post where it was told that the task was possible.

 

Labels (2)
17 Replies
siddharthsoam
Partner - Creator II
Partner - Creator II
Author

clipboard_image_0.png

Apologies I am receiving the same error even after the  new code. I still think this is a limitation and we might have to switch to architectural changes, happy to be corrected.

Lech_Miszkiewicz

Hi,

I will take some time later to build qvw and then qvf apps to test it and see which approach is possible.

I usually test my answers so i will stop guessing now and will get back to you once i have them tested.

regards

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
siddharthsoam
Partner - Creator II
Partner - Creator II
Author

Thanks a lot for your help  Lech.. that will be helpful !!

Lech_Miszkiewicz

Hi there,

So I have done my testing and there is only one way I was able to use to load qvw binary model to qlik sense app.

What i did is i created a section access in QVW (QlikView) with both NTNAME and USERID fields.

 

Section Access;
SeccAcc:
Load
	*
Inline
[
	ACCESS, NTNAME, 	USERID,		REDUCTION
	ADMIN,	ELVAIO\LECH, 	ELVAIO\LECH,	A
]
;
SECTION Application;

ELVAIO\LECH is my domain name.

I reloaded QlikView app, saved it and closed it. I also tested data reduction based on REDUCTION field which I  linked to my data model. It worked properly.

 

Then in Qlik Sense i simply used:

Binary [C:\Users\Lech\Desktop\sectionaccessapp.qvw];

(note that i have "Standard mode" switched off on my Qlik Sense engine which allows me to use UNC path instead of lib://, but this does not matter in this case). I was able to BINARY load sectionaccessapp.qvw and section access also worked straight away in Qlik Sense.

 

cheers! 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
siddharthsoam
Partner - Creator II
Partner - Creator II
Author

Appreciate that you took out the time to test..  I tried using userid and ntname in my section access code but still got the general error. I think i am not able to switch to legacy mode as i dont have the permission to do it.. In my case i will have to prefer changing the architecture and making an intermediate with the data model..

Lech_Miszkiewicz

You dont need legacy mode to run this. I only mentioned it to point out that i did not use Lib:// syntax, hovewer with Standard mode it is still working ok.

Next thing which comes to my mind is the version of Qlik Sense and version of QlikView.

I tested mine on QlikSense September 2019 and QlikView document created on the latest available QlikView version (whatever it is....)

and just to make sure:

you are running your tests on QlikSense server (not on Qlik Sense Desktop!!!)? Desktop does not support section access!

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
siddharthsoam
Partner - Creator II
Partner - Creator II
Author

Its not working in my case. I am using Qliksense server v11.24.5 and qlikview v12.10.20600 SR8.

An alternate i have for my case is to generate QVD's of the desired tables from qvw app at the end of my code and then use these QVD's in the qvf file.

Lech_Miszkiewicz

Well... from technical point of view it works for me, so it is possible to configure it with binary load.

What is not really documented is the compatibilty of the files. Your Qli Sense version seems to be quite old and QlikView is neither new. Maybe they are not compatible.

this is the question you can ask Qlik Support.

 

With QVD approach - yes it will work without issues but it requires additional scripting..

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.