Skip to main content

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
Dolphin
Partner - Contributor III
Partner - Contributor III

'$-Bug

Hi All,

I ran into a strange behaviour:

Pasting '$ from the clipboard (copied from outside of Qliks Text & Image Object Content, e.g. Title, Formula Editor, external Text Editor!) after a bold text causes the pasted value to be replaced by everything before that.

I suspect the the Text & Image Objects content does parse '$ in a special way and that's why there is a difference for the source of the copied string.

Repeating this even causes Qlik to crash eventually (connection to Server, not only the App) as all previous '$ will also cause previous text to be duplicated. When repeating, more and more * will appear, shortly after also / will appear. I shortly even saw the calculated HTML content before the crash.

When I ran into this issue I first ignored it and kept cleaning the the incorrectly pasted value. But then I ran into a case where it immediately crashed.

 

Has anyone experienced this issue? (qliksenseserver:14.67.13)

Also, why is pasting something causing the cursor to jump to the end of the Objects content?

 

Kind Regards,

Johannes

 

Labels (2)
1 Solution

Accepted Solutions
Alan_Slaughter
Support
Support

Thank you for submitting your request. Your case has been raised with our Engineering teams and is under investigation. However, there is currently no time-estimate for resolution as there is no impact on core product functionality. Therefore, you are kindly invited to subscribe to our Community Page in order to stay up to date on the latest news & releases and proceed with closing this request.

 


bug QB-14557
https://community.qlik.com/t5/Support-Updates-Blog/bg-p/qlik-support-updates-blog

https://community.qlik.com/t5/Release-Notes/tkb-p/ReleaseNotes

Should you have any other questions, doubts or concerns then please do not hesitate to reach out to us as we´ll

View solution in original post

4 Replies
Alan_Slaughter
Support
Support

Hi Dolphin, could you please provide detail steps and screens on how to recreate this issue?

 

Dolphin
Partner - Contributor III
Partner - Contributor III
Author

Hi Alan,

This is an example of a textbox, to replicate the issue:

Dolphin_0-1664269276909.png

1. Copy "'$" from the title or anywhere but a textbox itself.

2. Paste after "some text" to see the expected result

3. Paste after "some bold text" to see that "'$" is replaced with "some text some bold text".

Alan_Slaughter
Support
Support

Hi Dolphin, I did the following steps below. Does the same occur for you?
 

Open QS Hub, and select Text & Image chart.
 

  1. add '$
  2. Save it.
  3. Edit same sheet
  4. make '$ bold
  5. Save it
  6. It disappears.
Alan_Slaughter
Support
Support

Thank you for submitting your request. Your case has been raised with our Engineering teams and is under investigation. However, there is currently no time-estimate for resolution as there is no impact on core product functionality. Therefore, you are kindly invited to subscribe to our Community Page in order to stay up to date on the latest news & releases and proceed with closing this request.

 


bug QB-14557
https://community.qlik.com/t5/Support-Updates-Blog/bg-p/qlik-support-updates-blog

https://community.qlik.com/t5/Release-Notes/tkb-p/ReleaseNotes

Should you have any other questions, doubts or concerns then please do not hesitate to reach out to us as we´ll