Qlik Community

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
WE ARE LISTENING! New Navigation for Qlik Community, Sept. 26: TELL ME MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
arman0315
Contributor II
Contributor II

Frequent Read Lock for QVW in User Documents Folder

Hi All,

We have observed that one QVW deployed in our QlikView server often fails without any error in logs. We noticed though that failure is due to file kept read lock in User Documents folder by our service account running QV services. We are not able to determine though what is causing the lock, whether it is any specific QV service or process. Please advise. From task logs, we can see multiple inline load and a bundle load for images. Could these be causing issue or contributing factors?

Thanks!

Labels (1)
2 Replies
Mario_Petre
Support
Support

Since you mentioned this happens in your User Documents, make sure there is no Antivirus locking the file when receiving Open commands from other processes. Does this happen when opening the document in Access Point or during task execution of some kind? 

Task operations should not cause performance issues in your User Documents, unless the Source Documents path is on the same drive, same file server. This kind of parallel file operations can certainly slow a system down, as you are attempting massive reads and writes to and from the same disk. If this also happens to be HDD instead of SSD / flash based, it will be even more noticeable. 

For more details into what is interacting with those files, you can use the Handle tool from Sysinternals or Process Monitor from the same: Handle - Windows Sysinternals | Microsoft Docs

arman0315
Contributor II
Contributor II
Author

Hi Mario, thanks for your response.

The issue occurs during scheduled execution of the dashboard reload via task in QMC. There are hundreds of other reports in our platform but issue occurs only for the particular QVW and randomly. Source Documents path is on different drive from different server. Antivirus scan has been disabled for the User Documents path previously as well. 

Thanks!