Qlik Community

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Internal Engine Error Help

I've been having a lot of trouble working on an app getting this error over and over again. When the error occurs, I can't get into the specfic app at all but I am able to get into others.

Heres what I did:

Tried duplicating the app with QMC and adding it back to stream, the duplicate app works fine.

Soon after, I was continuing to do work on the duplicate app when the error occured again and then I was locked out of the duplicate.

So I decided to go back to the original file and it let me in, once again a few minutes later the internal engine error occurred and I was locked out of the original app. UPDATE AFTER WRITING POST: Although it let me back in to the first app after a short period, I'm now unable to access them AT ALL, it seems waiting does not help.

UPDATE 2 AFTER WRITING POST: I was let back into the original app again, so it seems that this is totally random.

For context, I've been trying to merge two apps into one, one has been edited heavily and the other is brand new, just using the data-auto-load to generate associations between tables.

In this case I have a section in the data load editor to handle "Invoices" (existing app): Table A, Table B, Table C, Table D, Table E (also worth mentioning that these are all left joined into one table during the load)

and another section to handle "Agreements" (new one) : Table A, Table B, Table Z, Table U.

As you can see, they both share Table A and Table B in common. Although, Tables Z and U are unique but contain fields in common with the other tables.

Qlik's automatic way of handling these is by turning 'DuplicateField' into 'TableA.DuplicateField' and 'TableB.DuplicateField'

So in order to remove synthetic keys and have successful data load I've gone through and manually put in 'TableZ.DuplicateField' etc since Qlik would normally make it 'DuplicateField' on Table Z thus creating a loop in the data.

I figured theoretically if I did this for each duplicate field that my problems will be resolved but I can't even test it because I get this internal engine error randomly and then I'm totally locked out of my app for a period of time.

Our Qlik Manager went into the Operations logs to see if there were any records of these errors and he was not able to find any log.

This error has occurred from me trying to load data and even when I just changed the order of the sections in the drag and drop on the data load editor without trying to load it.

Any solutions or ideas?

Please let me know if I am not making sense or articulating my problem clearly, thank you.

UPDATE 3: Despite the error occurring, when I was able to get back into the original app, my changes to the data load editor were kept and I was able to successfully load data with no errors, because of this, I can't even begin to guess what was causing that error, but I now know that it wasn't due to the changes I made in the data load.

3 Replies
Contributor II
Contributor II



have you found a solution for the problem yet? We faced exactly the same problem last week.


Engine fails while reloading script -> all the users get kicked off the server and applications are not available for a short period of time (few seconds) --> afterwards everything seems okay (even reloading exactly the same script is possible?? ). But after a while the error occurs again (only at the end of the loadscript - after finishing search index - and totally random)

UPDATE (18.01.2019): Application also crashes while selecting and working on the surface - not only in script. Also other applications have started showing this error. We´ve already reported the error to our consultant - I will let you know what the solution was.


We also tried to move the application to our dev-server but the error appeared there too.


In the Operations Monitor and in the Logs are entries with an engine error and a repository warning from the time where the engine crashed and the users cannot access the hub but no specific description or service message is available.


Hope somebody knows this issue - Thanks in advance.

Creator III
Creator III

did you find any solution for this?

Contributor II
Contributor II

Hello qlik4asif, 

the solution was to reproduce the whole application by copying the script and rebuilding the surface (since the copy sheet function hasn´t been available at that time yet)

Best regards.