Skip to main content
Announcements
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
cancel
Showing results for 
Search instead for 
Did you mean: 
ramya_grandhi
Contributor III
Contributor III

NaN value in KPI

Hi Everyone,

While I am trying to calculate the Gross Profit% I am getting NaN as a value in KPI in Qlik Sense Desktop. Anyone please suggest me how to resolve this.

Thanks in Advance.

4 Replies
timpoismans
Specialist
Specialist

Please give us more info on what measure you are using, the data you have. Or give us a sample app with dummy data.

rubenmarin

Hi Ramya, probably the second part of division is not being evaluated, and can't do a division by zero or null(), try setting the denominator in a separated expression to check the value returned.

ramya_grandhi
Contributor III
Contributor III
Author

Hi Marin,

I found that denominator is giving 0. My requirement is to create a new dashboard with the given qvf (Generated for ID-10) but I need to change one filter condition (ID-20) in data load script. After changing the filter condition and reloading the data I am getting all 0 values in the dashboard.

I am wondering why is this happen because the same dashboard worked well for ID-10 but when I changed the condition it is giving me zero's in all the calculations

timpoismans
Specialist
Specialist

Most likely this would indicate that there's an issue with the data associated with ID-20 (or the filter).

But it's hard to say without having an example application.