Qlik Community

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
wailengwoo
Partner
Partner

Navigation button extension not working

Hi,

I have installed the latest November 2018 release (with patch 1) for QS Desktop to test some of the new features. I tested the navigation button included in the bundled extension to test navigate to a specific sheet and it doesn't work.

Has anyone tested this? Is this a bug?

 

Labels (1)
28 Replies
stevegpage1
Partner
Partner

We are also having this issue on one machine. It works on most of our developer's laptops (running Feb 2019 QS Desktop), but have one where it does not work at all. The Navigation button is the only one that doesn't work. It works fine in our Enterprise environment, most laptops, just not on that one laptop. The only difference with that laptop is that is a Dell laptop that has a touchscreen. (I've also tried turning the touchscreen mode on and off)

Here is what we have done to try to solve this problem:

  • Tried building buttons from the beginning, in a new app, including the simple "Next Sheet".  The button does nothing. 
  • Changed default Browser from Firefox to Chrome. 
  • From the Control Panel, "Repair" on bundle extensions. 
  • Deleted the extension folder and copied the folder from a machine where it does work. 
  • Uninstalled QlikSense and Reinstalled QlikSense, ensuring all the options for bundles were selected.

Any advice or update on this problem would be greatly appreciated.

Senior Qlik Architect
Grey Matters Defense Solutions
radmin5253
Contributor III
Contributor III

Steve at the office we are using the Qlik Sense Enterprise version  February 2019 release and we have been informed through our Qlik representative that the issue is fixed in the April 2019 release. How ever  at home I am using the April 2019 release desktop version of Qlik Sense and I have the same problem at home. The button worked fine until I started to explore the capabilities and once it becomes inoperable I have not been able to find a way to make it operable again I tried everything you listed and it still does nothing. It will be interesting to see if it starts to work when we move to the April 2019 release at the office but I suspect that will not happen for at least another 4 - 5 months. In the mean time we reverted back to the Sense Navigation Extension which  works like a charm and allows you to set a background color for the button which I see can be done in the video but have yet to figure out how to do it with the dashboard bundle version provided by Qlik in the February release version.

Any way if you happen to find a solution please post back our CIO wants us to do away with all extensions and use only the features that come with Qlik.

wailengwoo
Partner
Partner
Author

I have upgraded my desktop version to April 2019 Patch 1 from November 2018 patch 3 and the navigation button still doesn't work.  I am surprised that after 2 more releases and it is still not working.  @radmin5253 , did Qlik acknowledge this as a bug? Cant seems to find any reference on this in the April 2019 release notes.

bielefeldt
Contributor
Contributor

We just upgraded to April 19 server version. We do only have that problem in an Internet Explorer Browser. Firefox and Crome works. Have others experience problems with the IE browser?

radmin5253
Contributor III
Contributor III

Wailengwoo I do not have direct access to our account rep. my team submitted a list of bugs found with the February version of Qlik Sense Enterprise to the lead team and their lead submitted to the Qlik rep. what I received back was that Qlik was aware of our issues and that they should be resolved when we move to the April 2019 version.

We submitted a rather large list of bugs chief among them the inability to get the dashboard buttons to work once they ceased. We have this problem in every browser Edge, Chrome, Safari, and IE.

I will not really know any more until we decide to move forward with the April version and in my organization things move slow and deliberately lots of hoops to jump through and signatures to get before we can move forward.

In any event we have been authorized to utilize the Sense Navigation extension until such time as Qlik gets their version fixed and frankly I like it better. Not sure if they are related or not meaning the dashboard version is a stripped down version of the extension but the dashboard does not seem to have the same appearance options that the extension has nor does it seem to match the promotional videos that Qlik put out mainly the ability to change the background color unless I assume you create a custom theme which again our organization and CIO does not allow. We use straight out of the box.

If I had to choose one new enhancement I would like to see in Qlik Sense it would be more flexibility in style changes text color, font, text size etc. from within the chart functionality as opposed to doing custom themes.

But hey that is just my pain points at present button failures and styling. I hope they get this fixed as it sheds a shadow over other dashboard bundle elements and visualizations bundle since they say they are Qlik verified.

 

wailengwoo
Partner
Partner
Author

I have tested this again using the browser (Chrome, IE and Edge) to access my hub instead of accessing it directly using the desktop app and voila it works. It just doesn't work from inside the desktop app

robertbrooks
Contributor II
Contributor II

I am facing the same issue. The button works in browser but not on our desktop App. Did you find a fix for the desktop app?
wailengwoo
Partner
Partner
Author

@robertbrooks , still not working after upgraded to June 2019 SP4. I cant remove the extension bundle to reinstall unless i uninstall and install Qlik Sense desktop

Onyi_Nwabia-Robbins
Contributor III
Contributor III

@wailengwoo 

Apologies for the severely late reply. We gave up due to time constraints and started using vizlib extension library. We didn’t raise a ticket for this as we had other tickets and found a different solution that worked out for the better.

Sorry it isn’t more useful information.