Skip to main content
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
Showing results for 
Search instead for 
Did you mean: 

Qlik Sense publishing app and clearing selections bug?

Hi all

I have a Qlik Sense file on server that changes selections when I publish it. I clear the selections on a non-published version of the file and when I publish that to a new name, new stream or replace any previous published file the selections come back in the published files. I think that the Server is holding selections whenever an app is published..,,

When I open up the new version of the published file the old selections are still there but I when I open up the copy that is not published the selections are cleared.

It appears as if the Qlik Sense Server is keeping the user selection in the published app even if I override the app. I've had some issues with clearing selections in Qlik Sense and this was occurring on apps that weren't published however I resolved that with the trick of reloading the app whilst it is running in a separate tab. I tried that here but it did not work. Also I tried saving of the app onto a desktop environment version of Qlik Sense and making changes, saving then reloading it back into the server. I have tried both of these for this issue and neither work.

None of it makes sense other than that there is something going on with the publish action in my Sense Server.

Can anyone help?

3 Replies
Contributor II
Contributor II

Hi, I've had this problem before and this is the only thing that seems to work:

1) Clear all selections

2) Go to your data load editor, and remove the fields from your data model that have the sticky filters applied (comment them out).

3) Reload the app (it will save automatically)

4) Go back to data load editor and restore the fields.

5) Reload the app again.

Use this "cleared" app to publish or overwrite any published apps.


Thanks Gerhard

This has worked. It's just weird because the solution that I was using before (opening up the app in 2 tabs and reloading it in one of them) was working. Then all of a sudden that process wasn't.

Anyway, hope Qlik fixes this soon because with Mashups there is sometimes a need to pass into the app a default state of selections.

Not applicable

When you see sticky filters appearing on your app, do the following:

1. Open the app and data load editor parallelly on 2 different tabs
2. Remove the filters on the app

3. Hit the save button on the data load editor (make sure the asterisk on the name of the tab goes away - this means the app was successfully saved)

4. Reload your app. You should now see that the filters have gone away!

If the above solution doesn't work, go to the QMC and duplicate your app and repeat the process described above on the duplicated app. This should solve your issue.

Happy Qlik-ing!