Qlik Community

Ask a Question

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

April 22, 2PM EST: Learn about GeoOperations in Qlik Sense SaaS READ MORE
Showing results for 
Search instead for 
Did you mean: 

Reload the script after changing the table

Hello everyone,

I am loading in tables and doing calculations in the following manner:

step 1: Load Table A from SQL

Step 2: Load table B from SQL. Based on a match, pull some values from Table A and assign them to records in Table B.

Step 3: Some values are not assigned in Table B because there was no match in Table A. So, i create a Table C which will have all the missing values from Table A and then i JOIN Table A and C (Some kind of Concatenation). 

NOTE: Now Table A has new rows that were generated by Table C. So far, all this works !

My task:

I want to reload Table B in a way so it can use the new data from Table A and assign the values.

Known problems:

Since i know what the values missing from Table A (in this case) i add them to the SQL and do the load without creating Table C and the app works fine. All assignments are correct. However, when i try the method stated above and create Table C, concatenate with Table A and reload Table B the second time, the assignment is still not done even though the rows exist in Table A now. 

My ask:

How can i reload Table B so it the assignments are done correctly?

Following images will be used to illustrate the above issue:

Table A:

Table A.PNG

Table B:

Table B.PNG

You can see the in the last column pointed at by the ridiculously big blue arrow that there is a null value in row 3 which means the correct value doesnt exist in Table A.

Table C:

Table C.PNG

the above table is created at run time by filtering out the Nulls from Table B>Column LINKTORULE (pointed by blue arrow)

Table C and A joined:

Table C and Tbale A Joined into 1.PNG

Table C is joined at the end of Table A which is desired output.

What i have tried so far:


Load *
Resident [Table B];
Drop Table [Table B];

Result of this:


as it can be seen, the new values are not fetched from Table A.

I appreciate any help. Thank you.

Labels (4)
0 Replies