Qlik Community

Ask a Question

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
QlikWorld Online 2021, May 10-12: Our Free, Virtual, Global Event REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
kdaniels-obrien
Partner
Partner

Set date range picker to default

Hi, 

I am using the Date Range Picker in my sheets.  I would like to set the date range picker to default to today's date...  But I would also like to allow users to select different days if they chose to. 

So I expect that when the user opens the sheet, all of the data is filtered to today's data.  The user can also select another day's worth of data by selecting new days in the date range picker. 

Right now, I have set vDefaultDate in my load script to today(): 

Let vDefaultDate=today();

In the sheet edit mode, I set the date field to =$(vDefaultDate) but it doesn't seem to apply the filter and I can't select another set of days... Can someone help me with this problem?  Thanks in advance! 

Labels (3)
3 Solutions

Accepted Solutions
lorenzoconforti
Specialist II
Specialist II

In your Date Picker object under Field, enable Advanced Setup then set Start date and End date to:

=vDefaultDate

It will default to the date you are defining in the script and will allow the user to change it

View solution in original post

kdaniels-obrien
Partner
Partner
Author

Nice, that worked! Thank you

View solution in original post

lorenzoconforti
Specialist II
Specialist II

Glad it worked

Please set the thread as solved

View solution in original post

3 Replies
lorenzoconforti
Specialist II
Specialist II

In your Date Picker object under Field, enable Advanced Setup then set Start date and End date to:

=vDefaultDate

It will default to the date you are defining in the script and will allow the user to change it

View solution in original post

kdaniels-obrien
Partner
Partner
Author

Nice, that worked! Thank you

View solution in original post

lorenzoconforti
Specialist II
Specialist II

Glad it worked

Please set the thread as solved

View solution in original post