Qlik Community

Ask a Question

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
April 22, 2PM EST: Learn about GeoOperations in Qlik Sense SaaS READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
afiedlerlizardi
Partner
Partner

URL represented as a link in table isn´t working

Hi all,

in data model we have a field which is containing an URL like the following one:
file://<SERVERNAME>/<FOLDER1>/<FOLDER2>/<FILENAME>  

The URL will be created in data load script with following script part:
Trim(if(IsNull(FileURLName) or FileURLName = ' ',
'file://<SERVERNAME>/<FOLDER1>/ ' & Right(FileURLName, LEN(FileURLName)-FindOneOf(FileURLName, '/', SubStringCount(FileURLName, '/') - 1)),
'file://<SERVERNAME>/<FOLDER1>/ ' & ProjectID & '/' & URLName))
as FileURLName

This URL should be shown in a table object best with a direct link to the file provided in the path the URL is representing.
A click on this Link should directly open the file or start a download in browser.

For this I show the URL in a Qlik Sense Straight Table object and chose "Link" as representation.
In table the URL will now be shown as a link, but clicking on it does not start the download as expected.
Qlik Sense and Browser (in this case Chrome) are not reacting in any way.

I also provided a second field in my table which is containing the URL as text.
If I copy this value out of the cell and put in the address line of the Browser the download of the file is directly starting.

The only difference I can see is that Qlik Sens is converting special chars like Space, % and so on into URL conform signs if I hover the link in table object.

Do someone of you have an idea what´s going wrong here?
I currently don´t have an idea what´s the reason for this unexpected behavior.

Kind regards and thank you very much for your support in advance
Alex 

Labels (4)
3 Replies
afiedlerlizardi
Partner
Partner
Author

I further tried around to find a solution in that case.
If I use an URL starting with "http://" or "https://" the link is working properly.

Is it possible that there is a security restriction implemented or active which disallows to download or open files from a file server?

stevedark
Luminary Alumni
Luminary Alumni

Hi @afiedlerlizardi 

I can imagine that the links only work with those two protocols.

Is it possible to get some kind of web server over that location so that you can use https? One possible route is setting the location up as a Content Library in Sense and using a URL there. This post explains more:

https://www.quickintelligence.co.uk/qlik-sense-web-server/

Using Content Libraries is quite neat, as you can then use the Security model in QMC to secure access to that folder.

Where it may break though is if files are getting created in that location, which the content library will not know about. Using IIS or Node.js may be an alternative.

Hope that helps,

Steve

afiedlerlizardi
Partner
Partner
Author

Hi Steve,

thank you very much for your response and the ideas.

I will forward the ideas with the web server and the Content Libraries to our customer.
Then he can best check if these two approaches are technical feasible and useful.

I further tried around and tried also to use the URLs in Microsoft Egde and here the URLs are working and the files will be downloaded/opened.
Based on this experience it looks like that this issue is only existing with Google Chrome.

Does someone else made such experience with URLs in Qlik Sense tables?
Are there any ideas how this issue with Chrome could be solved?

Kind regards
Alex