Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
VRaducan
Partner - Contributor III
Partner - Contributor III

Qlik Catalog Podman catalog-licenses container

Hi everyone,

we are proceeding with a catalog installation to a customer but we came to a halt.

The O.S. is RHEL8.6 ...

I've installed the pgsql, tomcat and podman, (the service does not instantiate automatically even thought I've run the post isntall .sh script, but this is a minor problem) The problem now is that when I access the Catalog http:/catalogmachine:8080/qdc we got a licenses service error.

I am trying to investigate a bit, before we have the next call with the customer...

From what I can see, watching the licenses container logs in podman we got this error: 

0)","timestamp":"2022-07-15T12:50:09.514513488Z"}
{"caller":"builder.go:439","corrId":"8a78abba-21a3-4e84-aa90-770f8a35721f","error":"dial tcp: lookup \u003cpostgres-server-ip-address\u003e: no such host","level":"error","message":"failed to initiate persistence, retrying in 5 seconds (1)","timestamp":"2022-07-15T12:50:14.514877412Z"}
{"caller":"builder.go:439","corrId":"8a78abba-21a3-4e84-aa90-770f8a35721f","error":"dial tcp: lookup \u003cpostgres-server-ip-address\u003e: no such host","level":"error","message":"failed to initiate persistence, retrying in 5 seconds (2)","timestamp":"2022-07-15T12:50:19.515142913Z"}
{"caller":"builder.go:439","corrId":"8a78abba-21a3-4e84-aa90-770f8a35721f","error":"dial tcp: lookup \u003cpostgres-server-ip-address\u003e: no such host","level":"error","message":"failed to initiate persistence, retrying in 5 seconds (3)","timestamp":"2022-07-15T12:50:24.515371157Z"}
{"caller":"builder.go:439","corrId":"8a78abba-21a3-4e84-aa90-770f8a35721f","error":"dial tcp: lookup \u003cpostgres-server-ip-address\u003e: no such host","level":"error","message":"failed to initiate persistence, retrying in 5 seconds (4)","timestamp":"2022-07-15T12:50:29.515682667Z"}
{"caller":"builder.go:439","corrId":"8a78abba-21a3-4e84-aa90-770f8a35721f","error":"dial tcp: lookup \u003cpostgres-server-ip-address\u003e: no such host","level":"error","message":"failed to initiate persistence, retrying in 5 seconds (5)","timestamp":"2022-07-15T12:50:34.515935538Z"}

Beware that the customer's machine is "locked" and has no access to internet apart from these sites: 

redhat.com
*.qlik.com 
github.com
archive.apache.org

rpm.nodesource.com

registry.npmjs.org

 

It does looks to me that the service is not able to access a postgres server IP.

I am going now through the postgresql configuration and check that...like the pg_hba.conf file in /var/lib/pgsql .... ecc...

And I'll have a look there...meanwhile...I've noticed something else: 

If I launch the container manually from /usr/local/qdc/qlikcore/

(qdc) ./launch_qlikContainers.sh

is not working and goes in timeout because it tries to pull the containers from qliktech-docker-release.jfrong.io/engine:12.722.0... 

and that site it's closed because of the Server's proxy.  (we've already asked them to open for us *.jfrog.io)

Whilst if I go in the root directory:

cd /

and the

cd /tmp/podium/bin/qlikSenseIntegration/ 

(this is the folder where i've downloaded the installer) 

and then launch the

(qdc) ./launchContainers.sh

it works and

(qdc) sudo podman ps

gives me the list of the containers.

.........any thoughts?

It has to pull the container from jfrog before the start? Is that's why is blocked ? 

But then, why when making it start from the download zone where also other files are present the .launch Containers.sh script instantiates the containers, whilst from the installation path it does not? 

Thank You

Vlad 

 

 

Labels (1)
10 Replies
VRaducan
Partner - Contributor III
Partner - Contributor III
Author

Hi Everyone just FIY,

the customer had a proxy as stated earlier.

The problem was the podman containers service which did not get all the proxy configuration from the system (as per stated in the podman official documentation...we've also tried to force the configuration under /usr/share/containers.config but no use)

Solved modifying the pod_qlikContianers.yml file which resides usually in /usr/local/qdc/qlikcore 

Modifying the file and inserting the proxy parameters under LICENSES_CONNECTION_STRING

- name: PROXY URI 

value: http://proxyOfTheCustomer.local:portOfTheProxy/

- name: LICENSES_CONNECTION_STRING
value: host=xx.xx.xxx.xxx port=5432 user=licenses password=xxxxx dbname=licenses sslmode=disable
- name: PROXY_URI
value: http://xxxxxxxxxx.xxxxxxxxx.local:portnumber/

 Thank you everyone.

BR 

V