Skip to main content
July 15, NEW Customer Portal: Initial launch will improve how you submit Support Cases. IMPORTANT DETAILS
Showing results for 
Search instead for 
Did you mean: 
Partner - Creator
Partner - Creator

Using QlikWebConnectors.exe and QlikWebConnectorsSVC.exe

Hi There,

I am using subject .exes to run an extract from Google Sheets. I developed against the  QlikWebConnectors.exe  and that runs perfect. After completing the developments I wanted to run it thru the QMC and via the QlikWebConnectorsSVC.exe as a service. I used the Install service.bat and managed to install the service, run as admin. After starting the service, logged on as local system and running the qvw it end in error reporting that the first column is not found. I stopped the service and let it login as the same user that runs the Qlik services but that generated the same error.

Stopping the service, running the QlikWebConnectors.exe  and leaving it open allows the qmc reload the qvws succesfully. 

I do not know what is going on, but I would like to get this resolved. Any ideas or advise???

3 Replies
Former Employee
Former Employee

Couple of things to ensure you have covered the available bases:

If you have already looked through all that info, just confirm back that nothing there did help, and I can see if I can get someone else to have a look, but I am also going to move the post over to the Connectors forum too, as that is where that team is looking for things to check, so that is likely the better place for this one too.


To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Partner - Creator
Partner - Creator

Hi Brett, 

I went through the first 2 documents. We are using the webconnector for Google drive and the setup was successful as long as we use the QlikWebConnectors,exe instead of QlikWebConnectorsSVC.exe. I was able to add the service and I have attached the Service Startup Log from this morning when I tried to run the qvw via the service again. But it failed. The stop at the end is by me, since I need to refresh the data manually to ensure there is no interruption at the workshop or the office where this data is reviewed.

I also looked at the License tab where info could be entered. We are using only the Google Drive connector at this time, so I do not believe I should have license info entered.  

We are also not allowing external connections to our Qlik server. Data will only be extracted from the server itself and controlled by reloads from the management console or in future the publisher. 

I have also added the qvw reload log files for a failed and successfull reload. The qvw file did not change, the only difference between the 2 is reload via connector service or via connector in session. 

All 3 files are in the attached zip file

I think we will need further help to investigate why things fail.

Partner - Specialist II
Partner - Specialist II


Have you checked for any useful info in the logs? You can see these in the Qlik Web Connectors user interface on the 'Log Files' tab.

Another thing you can try is just pasting the URL to QWC in your load script which you can see between the square brackets:

FROM [http://localho.....] (qvx)

In the log into a browser running on the same machine where the reload is taking place and you will often get the error message which is causing the problem. - BI | Software | Qlik Integration Services
GitFirst - A CI/CD solution for Qlik Sense