Skip to main content

GeoAnalytics

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
GMNandan
Contributor
Contributor

Add image to Qlik sense Application sheet as background and insert KPI box over it

I need to insert shop layout  in the back ground of Qlik sense application sheet and insert simple KPI chart over it to indicate Machine which are in fault as red color.  when I try inserting it, it is asking URL  but I don't have access to internet to server.

I have asked the IT incharge to upload the Image in QMC and He has copied the URL which was showing in QMC 

"/content/ashdkhd-asdjkhsd-fgaksjdha-gsjdhasd/headline.png " in the URL but it is not working.

3 Replies
Patric_Nordstrom
Employee
Employee

Use the developer tools (F12) in the browser to check why the url is failing in the native map chart.

The url should be a Qlik string  ='http...'

Thanks,

Patric

dirk_fischer
Creator
Creator

Hi Patrick,

I'm trying to do the same thing, use an image as background layer and have added the image to the application defaults.

I tried to use the value from the QMC field  Content, which is %StaticContentRoot%\Default\MY_IMAGE.png. This I entered with ='%StaticContentRoot%\Default\MY_IMAGE.png' into the URL field of my background layer.

But then the browser returns the error message 400 bad request. (https://myserver/sense/%StaticContentRoot%/Default/MY_IMAGE.png.

I use QlikSense November2019 Patch 4.

Do you have an idea, what's wrong?

I would appreciate very much if it was possible for you to give me some support on this one.

 

Thank you very much for your help.

 

Best regards

Dirk

 

dirk_fischer
Creator
Creator

Hi GMNandan

I don't know, if you already solved your problem. I added the images to a static content library via the QMC, where the library name is MES_IMAGES.

If I use the string '../Content/MES_IMAGES/MyPicture.png' in the URL it's working.

So maybe you want to try '../content/ashdkhd-asdjkhsd-fgaksjdha-gsjdhasd/headline.png' and see if this does the trick for you too.

Best regards

Dirk