Qlik Community

GeoAnalytics

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
monyedra
Partner
Partner

Error connecting to server (404) GeoAnalytics

We have a server with GeoAnalytics and other server with Qlik Sense that communicated between, when I dragged the map in app, I changed the server URL of https://maps.qlikcloud.com/ to //MyServerGeoAnalytics.com, but the map displayed " "Error connecting to server (404)"

This problem presented when I upgrade the version of Qlik Sense Server 3.2 to Qlik Server June


I'm using Qlik Sense June 2017

I have a Geoanalytics license

In the Qlik Sense Server I installed: QvIdevioConnector version 1.6.1.0 and GeoAnalytics Plus version November 2017.

In the GeoAnalytics Server, I installed: Qlik GeoAnalytics Server, version 4.5.1, Release November 2017


The same, we tried the url web and it is ok

Both servers communicate to Local Qlik GeoAnalytics

Both servers are for https

and both are using port 443


Attached images

Port 443 and 80.png

Error connectiong to server GEOA_1.pngServer GeoAnalytics.pngFriendly Geoanalytics.png


How to fix this problem?

18 Replies
monyedra
Partner
Partner
Author

Hi Patric,

We saw that the Geoanalytics Server certificate was created in another domain, so the proposed solution is:

"Currently as they send to call the services https: //myserver.dominio.corp/ravegeo/ does not match the certificate since it is generated for the * .dominio.com.mx so it does not match. generate a domain geoanalytics.dominio.com.mx so that it matches the certificate * .cominio.com.mx

Then the services would have to send them to call https://geoanalytics.totalplay.com.mx/ravegeo/ "


What's your opinion?





Patric_Nordstrom
Employee
Employee

Hi Mónica

Yes, the certificate should match the fully qualified server name.

So, either use //myserver.dominio.com.mx (which you have cert for) or generate a new certificate for //myserver.dominio.corp

Thanks,

Patric

sledison
Contributor
Contributor

Monica

Where were you able to change the URL from  https://maps.qlikcloud.com/ to //MyServerGeoAnalytics.com

I am having the same issue, and I'm sure it's due to this URL.

hardeep424
Partner
Partner

Hi,

Isn't it possible to run Qlik Sense on HTTPS and GeoAnalytics (GA) on HTTP?

For my case, I tried to generate the GA server certificate from Qlik Sense QMC. Then updated the GA settings to enable SSL. Then restarted the GA service. Now, GA can't be accessed neither on HTTP nor on HTTPS. Checked the GA server and found out that the GA server stops listening to both ports (8080-HTTP & 443-HTTPS).

If I disable SSL and restart service, then GA can work properly on HTTP.

So, the certificate generated by QMC for GA server won't work? We need to buy the trusted certs only?

Regards,

Hardeep

Patric_Nordstrom
Employee
Employee

Hi,

No, you can't mix https and http, the browser security settings won't allow it.

The recommendation is to have the QS server and the QGA server on different machines.

Both servers uses 80 and 43 but it is possible to change ports from default during installation.

Self signed certs are no good, use always trusted certs.

More info read the detailed guide: Qlik GeoAnalytics Enterprise Server Installation Guide

Thanks,

Patric

delporte_marcel
Partner
Partner

I have the same problem. With the url https://maps.qlikcloud.com everything works, and when i change the url and enter the server there i get the following error:

Error connection to server (404)

If I insert the server url in the Internet Explorer, however, I get to the Geoanalytics Server Administration without any problems.

Qlik Sense April 18

Qlik Sense Server April 2018 (12.16.2)

Qlik GeoAnalytics Server June 2018

Qlik GeoAnalytics for QlikSense June 2018

I am grateful for every advice, I despair slowly ...

Patric_Nordstrom
Employee
Employee

The most common install problem is due to certificates. In order to work with https connection Qlik Sense, QGA Server must also be installed with https. Otherwise browser will complain and refuse to connect due to security settings.

Check the manual and make sure:

* The SSL certificate is valid, (self signed wont work)

* The certificate matches the full server name: machine.domain.com

Thanks,

Patric

delporte_marcel
Partner
Partner

Thanks for the help. We finally managed to reach the server.

sandra_agustina
Employee
Employee

Well, this post really help me a lot.

I tried to execute this url https://maps.qlikcloud.com/ravegeo/webmap5/script/webmap.nocache.js?key=XXXX:XXXX and found out that my certificate is invalid since using certificate from Local Computer->Trusted Root instead of Local Computer->Personal. So what I did next was re-install Qlik Geo Analytics Server and using cert from Local Computer->Personal, and finally it worked.

 

Thanks @Patric_Nordstrom