Qlik Community

Ask a Question

Knowledge Base

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER

Creating a New Sheet Object in QlikView AJAX client returns "No Such Page"

Sonja_Bauernfeind
Digital Support
Digital Support

Creating a New Sheet Object in QlikView AJAX client returns "No Such Page"

When attempting to create a New Sheet Object in the QlikView AJAX client, the pop-out window shows only No such page.

Nosuchpage01.png

Environment:

  • QlikView; any version
  • Microsoft IIS Webserver

 

Resolution

Click here for Video Transcript

Steps:

Verify that the Static Content MIME type .qvpp is added in Microsoft IIS.  (See Figure 1)

  • Open the Internet Information Service (IIS) Manager
  • Navigate to the QlikView site
  • Locate MIME Types
  • Add .qvpp as text/html

Fig 1Fig 1

Note: The release of QlikView April 2020 SR4 (12.50.20400) now adds the .qvpp MIME type to IIS automatically during installation or upgrade.  The previous versions of QlikView April 2020 require the manual addition of the .qvpp MIME type to IIS as described above.

Note: If using IIS, other settings may block the use of the .qvpp file. These settings can be identified using Google Chrome and a HAR trace. Look for 404 errors in the console. Solution provided by @mralbert.

Example:

The file C:\Windows\System32\inetsrv\config\applicationHost.config may need to have the .qvpp extension added.

<fileExtensions allowUnlisted="false" applyToWebDAV="true">
            <clear />
            <add fileExtension=".qvpp" allowed="true" />
            <add fileExtension="." allowed="true" />
            ...
</fileExtensions>

 

Related Content:

 

Internal Investigation ID

  • QV-21496
Tags (1)
Labels (1)
Comments
mralbert
Contributor II
Contributor II

Hi @Sonja_Bauernfeind

We are running into this issue after upgrading to QlikView April 2020 SR1. We checked MIME Types and the entry for .qvpp was missing. We added the entry for .qvp and cycled IIS. However, we are still experiencing the "No such page" error. Is there anything we missed?

Thank you,

Matthew

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @mralbert I am not aware of any other issues causing this one at the moment. It may be worth posting this in our QlikView forums to get a little more visibility to see if someone else has had the same issue. I assume you're using IIS?

You could try and rule out IIS by installing and activating a QlikView webserver. If that works, you'll know that you need to look into IIS as the culprit. If it doesn't, then it may be related to files that were upgraded (or maybe not correctly upgraded) when you... ah... upgraded 🙂

 

mralbert
Contributor II
Contributor II

Hi @Sonja. I checked the QlikView logs and found no errors. So, I started a HAR trace in Chrome and found something that pointed us in the right direction. There was a 404 error on a .qvpp file.

It turns out our company has more secure baseline settings in IIS. These IIS settings were blocking the .qvpp file. We had to add the following to the C:\Windows\System32\inetsrv\config\applicationHost.config file:

 

<fileExtensions allowUnlisted="false" applyToWebDAV="true">

                    <clear />

                    <add fileExtension=".qvpp" allowed="true" />

            <add fileExtension="." allowed="true" />

            ...

                </fileExtensions>

 

Hope this can helps others if they run into this as well! 

Sonja_Bauernfeind
Digital Support
Digital Support

@mralbert That's really good work! Thank you so much for coming back to us and sharing this with us, I am certain this will be valuable for others.

Thanks again 🙂

 

Version history
Revision #:
8 of 8
Last update:
‎2021-02-22 10:42 AM
Updated by: