Skip to main content
Announcements
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
cancel
Showing results for 
Search instead for 
Did you mean: 
AliAzizi
Partner - Creator II
Partner - Creator II

GeoAnalytics connector and GeoAnalytics Plus installation

We have installed GeoAnalytics connector and GeoAnalytics Plus for our customer. Before installing the GeoAnalytics Plus I tested the GeoAnalytics connector and get the error "Invalid key".

Then I tried to install GeoAnalytics plus. Java 9.0.1 is already implemented on the server.

 

When I try to create a connection towards GeoAnalytics plus, I receive the error below:

   

I tried several other ports on the server but the result is the same. By using “https://ga.qlikcloud.com” the connection will be established:

 

According to the GeoAnalytics installation guide: http://bi.idevio.com/geoanalytics/geoanalytics-plus-installation

If we don’t have GeoAnalytics server implemented, we should use the default values in the installation wizard. But as I’ve seen the default values in the GeoAnalytics installation wizard is different from those in the installation guide:

 

Item

Installation wizard

Installation guide

Location executor port

42024

42024

Location server URL

http://ga.idevio.com

https://ga.qlikcloud.com

Route server URL

http://route.idevio.com

https://route.qlikcloud.com

Geocoder Server URL

http://geocode.idevio.com

https://geocode.qlikcloud.com

 

I’m not sure which one is correct and should be used. Currently I use the values mentioned in the installation guide.

Any help is appreciated.

   

 

 

1 Solution

Accepted Solutions
AliAzizi
Partner - Creator II
Partner - Creator II
Author

Hi Jonas

 

Thank you for your reply. It is the first time I’ve installed GeoAnalytics on this server. The version is 5.8.2.

 

The default values in the installation wizard for GeoAnalytics Plus should be updated by Qlik as it still contains the old values, even though I have the latest version of GeoAnalytics connector on the server.

 

Regarding the Java version I’ve implemented the version 9.0.1 as mentioned earlier and it is working fine.

I got yesterday help from a Qlik consultant to review the installation together and we found the root cause for this issue:

 

When running the installation wizard for GeoAnalytics connector and select the Qlik Sense as installation it automatically enters the following path for the extensions:

 

C:\ProgramData\Qlik\Sense\Repository\Extensions

 

And it caused the problem. The correct path should be:

 

\<Qlik Sense Share>\StaticContent\Extensions

 

By changing the path the error message “Invalid key” was not appearing again and the connector was working correctly.

Regards

 

 

 

View solution in original post

4 Replies
AliAzizi
Partner - Creator II
Partner - Creator II
Author

Forgot to mention that I've installed GeoAnalytics on a Qlik Sense server (June 2017) version.

Jonas_Karlsson
Employee
Employee

Hi Ali,

The server we use is located in the domain qlikcloud.com, the other addresses you refer to are old and will not be visible if you download the latest versions. They will only be visible if you have older version of the extension/connector installed. so it´ll not be a problem for new users.

Right now QGA supports the latest public release of Java which as of today is Java  8 rel 151 64-bit version

Java Downloads for All Operating Systems

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

Regards,

Jonas Karlsson 

Qlik

AliAzizi
Partner - Creator II
Partner - Creator II
Author

Hi Jonas

 

Thank you for your reply. It is the first time I’ve installed GeoAnalytics on this server. The version is 5.8.2.

 

The default values in the installation wizard for GeoAnalytics Plus should be updated by Qlik as it still contains the old values, even though I have the latest version of GeoAnalytics connector on the server.

 

Regarding the Java version I’ve implemented the version 9.0.1 as mentioned earlier and it is working fine.

I got yesterday help from a Qlik consultant to review the installation together and we found the root cause for this issue:

 

When running the installation wizard for GeoAnalytics connector and select the Qlik Sense as installation it automatically enters the following path for the extensions:

 

C:\ProgramData\Qlik\Sense\Repository\Extensions

 

And it caused the problem. The correct path should be:

 

\<Qlik Sense Share>\StaticContent\Extensions

 

By changing the path the error message “Invalid key” was not appearing again and the connector was working correctly.

Regards

 

 

 

nasarkhann
Contributor III
Contributor III

We are facing the same issue. Installation directories and extensions directories are connect. can you please suggest a fix?

nasarkhann_0-1645085609884.png