Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

salleninsd
New Contributor III

Issue with Auto-Generated Script

Hello, I made some changes to my tables and when I re-loaded from Data Load Editor, the auto generated keeps putting the old field name into table.  I deleted the file from my attached files and reloaded, and that did not fix the problem.  I am reluctant to Unlock the Auto-Generated Section because I don't want to jack up my model.  I generally do not use the Data Manager.   The model was working fine before, and the fields I changed have nothing to do with this field.

I actually changed the name in my attached file from [Customer Name] to [CareTypeName] some time ago and have never had any issues until now.

 

Here is the error message on Load:

Customer Name Error.JPG

 

Here is the view of the Auto-Generated Script Section:

Auto-Generated script for Customer Name.JPG

 

Any feedback is much appreciated!

1 Solution

Accepted Solutions
Partner
Partner

Re: Issue with Auto-Generated Script

Hi,

What is see is that for the exact same file/tab you have a different first field. Is it possible that your file no longer contains the name [Customer Name] and now is called [CareTypeName]? Then you auto generated part is not valid anymore.

You can unlock the auto generated part and comment everything out.

Jordy

Climber

Work smarter, not harder
2 Replies
Partner
Partner

Re: Issue with Auto-Generated Script

Hi,

What is see is that for the exact same file/tab you have a different first field. Is it possible that your file no longer contains the name [Customer Name] and now is called [CareTypeName]? Then you auto generated part is not valid anymore.

You can unlock the auto generated part and comment everything out.

Jordy

Climber

Work smarter, not harder
salleninsd
New Contributor III

Re: Issue with Auto-Generated Script

Thank you, Jordy.

Yes, I changed the field name some time ago, and never had a problem.  I unlocked and fixed the issue in the auto-generated script, and everything seems to work out okay.  I've never unlocked and changed anything in the auto-generated section, and I just wanted to make sure that this action will not have a negative impact on my model.

I've never dabbled in this section, and wanted to be sure.  Fyi, I never really  use the Data Manager, and generally use the Script editor to make changes.

Thanks again!