Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
QlikWorld happening right now! You can still join: REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
khampvihi
Contributor
Contributor

Qlik sense data CSV vs Mysql

Hello,

I am totally new on Qlik. For my own test I create a very simple sample of datas from 2 sources CSV and Mysql.

For CSV we have 2 files : Order ( id | customer_id | order_sum ) and Customer ( id | name)

For Mysql I have 2 tables : Order ( id | customer_id | order_sum ) and Customer ( id | name)


In Qlik I insert and link then exactly same way = customer_id to id (for Customer). Now I create a chart showing Customer name with order_sum.

On the app with CSV all are correct. In Mysql for order_sum nothing is show...  Test and try several times it show nothing.....nada...


Any idea please ???

1 Solution

Accepted Solutions
rangam_s
Creator II
Creator II

Check by creating a table whether it is properly linked or not.

If Yes, then try converting sell_sum into number format in the load script and check.

View solution in original post

11 Replies
rittermd
Master
Master

Open the data model viewer in your app to see how the tables are linked and to make sure that it is correct.

khampvihi
Contributor
Contributor
Author

Ok here some captures :

Here u see CSV source datas and all fine :

csv01.png

See : NAME cross with SELL_SUM.

csv02.png

Here I do EXACTLY same datas from to my DB Mysql :

mys01.png

Here same paramaters but there is no graph appear no matter what I do on it....

mys02.png

And this is why I dont get .....

rangam_s
Creator II
Creator II

use NoConcatenate load for Second table.

shraddha_g
Partner
Partner

If both tables having similar columns with same number of count then it will auto concatenate.

To test, give source flag to both tables, it will help you understand which table have given you data in the chart.

Also check format of Customer Id in both sources.

If possible share your script, it will be easier to understand the case

rangam_s
Creator II
Creator II

Check by creating a table whether it is properly linked or not.

If Yes, then try converting sell_sum into number format in the load script and check.

bwisealiahmad
Partner
Partner

Hi,

Share either your script or app and someone will have it solved in no time.

I think it is formatting issue on the sell_sum. It looks like the data is connected right and both columns have left aligned data so think it is same type and seems like it has renamed it to a common column name.

Best,

Ali A

balabhaskarqlik

Can you check scripting variances in Both apps. In CSV app data connected properly, but in SQL app, think so there's a variance of Customer_id link with Id column in order table.

Might be that's causing the issue of data generation.

khampvihi
Contributor
Contributor
Author

Hello all,

Thanks so much reply. I manage to find it myself : just add the join to table and thats it...

balabhaskarqlik

If you resolve the issue, post the solution, easy to identify these kind off issues for others.