Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Creator
Creator

SQL##f - SqlState: S0002, ErrorCode: 208, ErrorMsg: [Microsoft][ODBC SQL Server Driver][SQL Server]I

HI Team ,

 

how to resolve below issue :

 

SQL##f - SqlState: S0002, ErrorCode: 208, ErrorMsg: [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name '#Temp'.

 

please help us my document is failing in qmc continuously.

 

Thanks In Advance

 

 

Labels (1)
1 Solution

Accepted Solutions
Highlighted
Support
Support

Hi @SNR1 

This is related to temporary tables in SQL Server, please refer to the following documentation that might help:

Look at the "Temporary Tables" section 

https://docs.microsoft.com/en-us/sql/t-sql/statements/create-table-transact-sql?view=sql-server-2017

Have you executed the SP from the Microsoft SQL Server Management Studio and verify that it runs successfully ? 

Have you asked to your internal team, dba admin if temp files are deleted at some point or if there is something going on in the TempDB?

Kind regards.

Note: if this suggestion helps to resolve the issue or answers your question, it will be appreciated if you select the "Accept as Solution" option.
We encourage you to visit our Knowledge Base https://qliksupport.force.com/QS_CoveoSearch when trying to find a solution related and not limited to: errors, feature requests, product defects. You can also visit our Qlik Help portal https://help.qlik.com/

View solution in original post

3 Replies
Highlighted
Support
Support

Hi @SNR1 

This is related to temporary tables in SQL Server, please refer to the following documentation that might help:

Look at the "Temporary Tables" section 

https://docs.microsoft.com/en-us/sql/t-sql/statements/create-table-transact-sql?view=sql-server-2017

Have you executed the SP from the Microsoft SQL Server Management Studio and verify that it runs successfully ? 

Have you asked to your internal team, dba admin if temp files are deleted at some point or if there is something going on in the TempDB?

Kind regards.

Note: if this suggestion helps to resolve the issue or answers your question, it will be appreciated if you select the "Accept as Solution" option.
We encourage you to visit our Knowledge Base https://qliksupport.force.com/QS_CoveoSearch when trying to find a solution related and not limited to: errors, feature requests, product defects. You can also visit our Qlik Help portal https://help.qlik.com/

View solution in original post

Highlighted
Digital Support
Digital Support

Nikhil, did Nadia's post get you what you needed, or are you still working upon things?  I do agree with her that this is a SQL issue, not a Qlik issue, we are simply returning the error sent back from the ODBC/OLE DB client connector in this case in our log...  Microsoft Support would be the likely experts on this one, but I suspect your SQL DBA's can likely assist as well.  Please leave an update as to where things stand, and if Nadia's post did help, be sure to circle back and use the Accept as Solution button to give her credit for the help.  You use the button on the post with the information that helped with things.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Creator
Creator

Thanks Brett/Nadia