Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Make your voice heard! Participate in the 2020 Wisdom of Crowds® Survey. BEGIN SURVEY
Highlighted
manojkumargowda
Contributor

Section access: chart hide not working in server

Hello,

I'm using below simple section access script to provide access to two users. Here Role='Tech' should see object TX01 and BUSER should not see this object. This is working quite well in local. But In server, When I try to open it from Access point, I'm getting error as "Failed to open document, You don't have access to this document.". 

I think issue is with OBJ_ACCESS table, because when I comment out this, it works fine in server as well.

Section Access;

LOAD * INLINE [

    ACCESS, NTNAME, ROLE

    ADMIN, DOMAINNAME\USERNAME, BUSER

    ADMIN, DOMAINNAME\USERNAME, TECH

];

Section Application;

OBJ_ACCESS:

LOAD * INLINE [

    ROLE, TX01

    TECH, 1

    BUSER, 0

];

4 Replies
Highlighted
MVP & Luminary
MVP & Luminary

Re: Section access: chart hide not working in server

Are you sure your ntname is the same if access the document through the access point? And make all field values and field names in the section access table are in upper case.


talk is cheap, supply exceeds demand
Highlighted
manojkumargowda
Contributor

Re: Section access: chart hide not working in server

Thanks Gysbert for your response.

Yes, NTNAME is same in both local and server. As I already mentioned when I comment out the OBJ_ACCESS table part, the document opens in Server and also section access part works (i.e. only these 2 specified users can open the dashboard). But when I Uncomment the Obj_access part, Document is not opening for anybody.

And As you can see in the above script, everything is in UPPERCASE even NTNAME also..

Highlighted
MVP & Luminary
MVP & Luminary

Re: Section access: chart hide not working in server

Is the OBJ_ACCESS table manipulated elsewhere in the script?


talk is cheap, supply exceeds demand
Highlighted
manojkumargowda
Contributor

Re: Section access: chart hide not working in server

No, Only above script is there in my qvw file. And one text box (TX01)  to show/hide as per section access.

I'm doing a POC on section Access with chart level access to implement in our project. But the above script is not working in server.