Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Highlighted
yrstruly
New Contributor

Straight Table Not Displaying All Column Data

I have a problem with this straight Table Not displaying all Column Data. What am I doing wrong. It contains multiple expressions. Only the "Load Factor' Column Data Display Always. Please Help?

 

Let's follow these steps to create our KPI straight table:

1. Go to Layout | New Sheet Object | Chart in the menu bar.

2. On the General tab, select the Straight Table option in the Chart Type section (bottom right icon).

3. In the Window Title input box, place the following expression and click on Next: ='KPIs per ' &GetCurrentField(Airline_Origin_Destination)

4. On the Dimensions tab, select the Airline_Origin_Destination cycle group from the Available Fields/Groups list and double-click on it to move it to the Used Dimensions list.

5. Click on Next to go to the Expressions tab.

6. Create three new expressions using the predefined variables (or enter their expressions directly, if you did not create the variables) and their corresponding labels: ° Load Factor %: $(eLoadFactor) ° Performed vs Scheduled flights: $(ePerformedVsScheduled) ° Air time %: $(eAirTime)

7. Click on Next twice to go to the Presentation tab.

8. Change the Alignment settings for all three expressions so that Label and Data (Text) are set to Right and Label (Vertical) is set to Bottom.

9. Under the Totals section, select the Totals on Last Row radio button.

10. Under Multiline Settings, mark the Wrap Header Text checkbox.
www.it-ebooks.info
Chapter 6
[ 195 ]
11. Click on Next to go to the Visual Cues tab.

12. For all three expressions, set the Upper >= value to 0.85 and the Lower <= value to 0.5.

13. Click on Next to go the Style tab.

14. Set Stripes every Rows to 1 and click on Next to go to the Number tab.

15. Set the Number Format Settings option for all three expressions to Fixed to 1 Decimals and enable the Show in Percent (%) checkbox.

16. Click on Next three times to go to the Caption tab.

17. Tick the Auto Minimize checkbox.

18. Click on Finish to create the straight table.

result straight table.PNG

Labels (1)
5 Replies
MVP
MVP

Re: Straight Table Not Displaying All Column Data

Check your variable definitions. If that is not the problem, I suggest that you upload your qvw for a closer look.
Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
yrstruly
New Contributor

Re: Straight Table Not Displaying All Column Data

airtime.PNGeload.PNGeload2.PNGperformance.PNGI did everything as instructed in the book. Look at the screenshots and tell me where i went wrong. It is just the Load Factor data that display? View  qvw file here: https://drive.google.com/file/d/1vorC6561Zgd5a5Ga3q5hv1OD-uCoqMvj/view?usp=sharing

 

Thanks.

yrstruly
New Contributor

Re: Straight Table Not Displaying All Column Data

Have you checked out my qvw?
yrstruly
New Contributor

Re: Straight Table Not Displaying All Column Data

Can somebody please assist me?
MVP & Luminary
MVP & Luminary

Re: Straight Table Not Displaying All Column Data

Who said the book is correct?  🙂

For the variable reference to work as an expression, two things have to be true. 

1. The variable definition must contain a valid expression. 

2. In your expression def, you must use the exact spelling -- case and spaces included -- of the variable name. 

The book told you to create the variable "ePerformedvsScheduled". It then told you to use "ePerformedVsScheduled" in the expression. Note the difference in "V".  In your case,  you also added a space in the variable name so your correct expression is "$(ePerformedvsScheduled )" (note the space after d). 

The best way to make sure your variable name is spelled correctly is to use the variable dropdown in the expression editor. See if you can use the drop down to correct your airtime expression. 

-Rob
http://masterssummit.com
http://qlikviewcookbook.com
http://www.easyqlik.com