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In Talend Studio, connection to Talend Cloud fails with 'forbidden' message

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TalendSolutionExpert
Contributor II
Contributor II

In Talend Studio, connection to Talend Cloud fails with 'forbidden' message

Last Update:

Jan 22, 2024 9:35:30 PM

Updated By:

Jamie_Gregory

Created date:

Apr 1, 2021 6:14:37 AM

Problem Description

In Talend Studio, setting up the connection to Talend Cloud fails with a forbidden message.

 

Root Cause

Users and Roles do not have permission to access Studio Data Management - Develop in Talend Management Console (TMC).

 

Solution

  1. In TMC, on the Management Console, select Roles > Operator > Permissions and ensure that Studio Data Management - Develop is on.

    0693p000008u9oGAAQ.png

     

  2. On the Management Console, select Users and verify that the User is assigned the Operator role.

    0693p000008u9mzAAA.png

     

  3. If the User has a custom role, verify that the custom role has the same permission, Studio Data Management - Develop, turned on.

    0693p000008u9giAAA.png

Labels (1)
Comments
Robert_Pence
Support
Support

Note that the "Operator" role can be edited and the permission "Studio Data Management - Develop" now called "Studio - Studio Develop" may not remain linked to it. The customer may for instance have a custom role more congruent than linking "operator" with developer. 

So make sure the user has the permission, not just the role. 

Also check the user's "Profile Preferences" and see that the "Studio user name" exists to confirm the permission is assigned; this is the username for logging in to Studio and may differ from their email used to login to Cloud.

Version history
Last update:
‎2024-01-22 09:35 PM
Updated by: