Do not input private or sensitive data. View Qlik Privacy & Cookie Policy.
Skip to main content

Announcements
ALERT: QlikView server communication interruptions following Microsoft Windows Domain Controller security updates

Qlik Replicate Endpoint Server not starting

100% helpful (1/1)
cancel
Showing results for 
Search instead for 
Did you mean: 
dima_etkin
Support
Support

Qlik Replicate Endpoint Server not starting

Last Update:

Sep 1, 2025 3:14:54 AM

Updated By:

Sonja_Bauernfeind

Created date:

Aug 12, 2025 10:20:00 AM

This article provides a solution for the Qlik Replicate Endpoint server not starting as expected. Symptoms of this include:

  • Endpoints are not listed in the Create new endpoint dialogue
  • The message One or more Endpoint Servers cannot be reached is displayed
  • The Endpoint Server appears in an "Error" state

About the Endpoint Server

The Endpoint Server is a Qlik Replicate JAVA subcomponent that will only start when an endpoint requiring it is enabled in the Qlik Replicate license. Most endpoints will not need it (as they are written in C). A list of those that do can be found in Endpoint Server | Supported Endpoints.

For more information about the Qlik Replicate Endpoint Server, see Endpoint Servers | help.qlik.com.

Symptoms

Sometimes, when enabling Qlik Replicate endpoints such as SAP, Salesforce, or MongoDB, either explicitly or by importing an all-open license, the Endpoint Server Component may not start up on a Linux Server.

One or more Endpoint Servers cannot be reached

When looking at Endpoint Servers in the Qlik Replicate UI and navigating to Server > Endpoints (A) > Endpoint Servers (B), you may see that it failed and might have even been registered on port 0 (C) : 

endpoint server cannot be reached.png

Endpoint not available at endpoint creation

The expected endpoint may not be available, even if it has been correctly enabled in the license. 

Resolution

  1. Review the parameters with which the /tmp folder is mounted on the server:
    sh-4.4$ cat /proc/mounts | grep /tmp
    tmpfs /tmp tmpfs rw,nosuid,nodev,noexec,seclabel,size=32G,nr_inodes=1048576,mode=1777 0 0
  2. Allocate a temporary folder in the Qlik Replicate file system and make sure it’s under the same owner as the rest of the product libraries. Generally, this will be the “attunity” user ID:
    sh-4.4$ mkdir /opt/attunity/tmp
    sh-4.4$ chown attunity:attunity /opt/attunity/tmp
    sh-4.4$ chmod 755 /opt/attunity/tmp
  3. Take a backup of your current /opt/attunity/replicate/bin/site_arep_login.sh
  4. Update the /opt/attunity/replicate/bin/site_arep_login.sh adding a line:
    export AT_JVM_OPT=-Djava.io.tmpdir=/opt/attunity/tmp
  5. Stop the Qlik Replicate server
  6. Load the new settings:
    sh-4.4$ cd /opt/attunity/replicate/bin
    sh-4.4$ source arep_ligin.sh
  7. Start the Qlik Replicate server

If the endpoint enablement prerequisites have been fully fulfilled, you will now see the new endpoints in the endpoint list, and the endpoint server will appear active and assigned to a non-zero port on the server:

correctly started endpoint server.png

 

Cause 

This issue is typically caused by the default Linux /tmp file system being mounted with the noexec option, which prevents any executable (.so or .jar) from running from any sub-folder on this mount point.

 

Related Content 

Endpoint Servers

Endpoint Server Not Connecting on Linux based Qlik Replicate

 

Internal Investigation ID(s)

SUPPORT-4605 

 

Environment

  • Qlik Replicate
Labels (2)
Version history
Last update:
‎2025-09-01 03:14 AM
Updated by: