Skip to main content
Announcements
July 15, NEW Customer Portal: Initial launch will improve how you submit Support Cases. IMPORTANT DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Manoj_Prabu
Partner - Creator
Partner - Creator

updating qConnectionSecret is not working in Data-connection api

Hi Community,

I was trying to update the Amazon S3 credentials in Qlik SaaS data connection dynamically using data-connection API. A week before the API worked fine, but now it is not. The link I followed https://qlik.dev/apis/rest/data-connections#%23%2Fentries%2Fdata-connections%2F-qID-put

I'm passing the following data:

{
  "qID":"string",
  "qName":"string",
  "qConnectStatement":"string",
  "qType":"string",
  "qEngineObjectID":"string",
  "qConnectionSecret":"accessKey=accessKeyValue;secretKey=secretKeyValue"
}
whereas in qConnectionSecret I'm passing wrong credentials intentionally to check the data connection update. Still the data connection is happening. Need help.
 
Thanks in Advance
Labels (1)
  • SaaS

1 Solution

Accepted Solutions
Manoj_Prabu
Partner - Creator
Partner - Creator
Author

Hi @Todd66 ,

Sorry for the late reply. I fixed the above issue by creating the initial connection through API.
On the 1st case I create the connection directly in the Qlik sense cloud data load editor and it works. After few week it didn't work.
So I deleted the old connection and created new connection through API and try to update the credentials through API. In 2nd case it worked.
Please try this 2nd method.

Thanks

View solution in original post

3 Replies
Todd66
Contributor III
Contributor III

Hello,                         LandstarOnline Login

Thanks for asking this because I faced similar kind of issue last time, I am still searching for some proper solution Same issue still no fix to this. 

Help

 

Manoj_Prabu
Partner - Creator
Partner - Creator
Author

Hi @Todd66 ,

Sorry for the late reply. I fixed the above issue by creating the initial connection through API.
On the 1st case I create the connection directly in the Qlik sense cloud data load editor and it works. After few week it didn't work.
So I deleted the old connection and created new connection through API and try to update the credentials through API. In 2nd case it worked.
Please try this 2nd method.

Thanks

DuncanJones
Contributor
Contributor


@Manoj_Prabu wrote:

Hi @Todd66 , Tower Defense

Sorry for the late reply. I fixed the above issue by creating the initial connection through API.
On the 1st case I create the connection directly in the Qlik sense cloud data load editor and it works. After few week it didn't work.
So I deleted the old connection and created new connection through API and try to update the credentials through API. In 2nd case it worked.
Please try this 2nd method.

Thanks


I am trying to get the access token or some way of login using python and submit the post request using python.