Qlik Community

Qlik Compose for Data Warehouses

Discussion board for collaboration on Qlik Compose for Data Warehouses.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
badgerriaan
Contributor III
Contributor III

Qlik Compose Mail Server Settings Issue

Hi,

I am having trouble configuring my Compose server to use an Office 365 account to send Notifications.

I have tried with and without the Use SSL option and all the ports: 25 and 587 (correct SSL port)
We do have a proper Wild Card SSL certificate installed on the Compose server also for HTTPS.

I have also tried using the Anonymous settings: Here I can receive the Test Mail fine, but without SSL and also the system never actually sends any notifications out when this is set up (Maybe an IT policy here).

Does anyone with some advice on how you set up your mail notifications?

The settings work fine when using them in Qlik Replicate, but I get this error when trying to use them in Compose:

MAIL SSL ErrorMAIL SSL Error

  • SYS,GENERAL_EXCEPTION,An error occurred while attempting to establish an SSL or TLS connection.<p><p>One possibility is that you are trying to connect to a port which does not support SSL/TLS.<p><p>The other possibility is that the SSL certificate presented by the server is not trusted by the system for one or more of the following reasons:<p>1. The server is using a self-signed certificate which cannot be verified.<p>2. The local system is missing a Root or Intermediate certificate needed to verify the server's certificate.<p>3. The certificate presented by the server is expired or invalid.<p><p>See https://github.com/jstedfast/MailKit/blob/master/FAQ.md#InvalidSslCertificate for possible solutions.
Labels (2)
1 Reply
TimGarrod
Employee
Employee

Hi, I have my Compose env setup to send notifications via office365 also - using the same config you have- 

TimGarrod_0-1634913393299.png

 

Both test emails and notifications work without issue... 

You may need to check with your email admin to ensure it isn't blocked somehow (for me the sender must be an actual email acct in office365 - I can't make up a "do-not-reply@...." type of address). 

TimGarrod_1-1634913460140.png