Qlik Community

Qlik Deployment Framework

This group hosts information related to the Qlik Deployment Framework (QDF). Providing best practices, libraries and utilities that facilitate the recommended setup and management of QlikView or Qlik Sense environments. An understanding of the Qlik platform is recommended before joining this group. Download QDF and documentation here: https://github.com/QlikDeploymentFramework/Qlik-Deployment-Framework/releases

Highlighted
rustyfishbones
Honored Contributor II

FABS not Working in Text Object

Hi All,

I can use FABS function in a straight table, however when I use it in a text object it does not return the correct result.

FABS(SUM({<TaskId = {'*ADJUST*'}>}[#Act-Second]))

Any ideas why it aint correct in the text object but its ok in the table, should I be removing the null values.

Regards

Alan

1 Solution

Accepted Solutions

Re: FABS not Working in Text Object

May be try this

Sum({<TaskId = {'*ADJUST*'}>} Fabs([#Act-Second]))

or this

Sum(Aggr(fabs(Sum({<TaskId = {'*ADJUST*'}>} [#Act-Second])), ChartDimensions))

4 Replies

Re: FABS not Working in Text Object

May be try this

Sum({<TaskId = {'*ADJUST*'}>} Fabs([#Act-Second]))

or this

Sum(Aggr(fabs(Sum({<TaskId = {'*ADJUST*'}>} [#Act-Second])), ChartDimensions))

rustyfishbones
Honored Contributor II

Re: FABS not Working in Text Object

ok, this works, but I need a better way

=FABS(SUM({<TaskId = {'*ADJUST*'}, [#Act-Second] = {">0"}>}[#Act-Second]))

+ FABS(SUM({<TaskId = {'*ADJUST*'}, [#Act-Second] = {"<0"}>}[#Act-Second]))

rustyfishbones
Honored Contributor II

Re: FABS not Working in Text Object

First one worked thanks

Partner
Partner

Re: FABS not Working in Text Object

I think the problem is the single quotes in the set expression.
Single quotes means exact value. Use double quotes to make a search.

FABS(SUM({<TaskId = {"*ADJUST*"}>}[#Act-Second]))

See the blogpost https://community.qlik.com/blogs/qlikviewdesignblog/2017/09/11/quotes-in-set-analysis