Qlik Community

Qlik Deployment Framework

This group hosts information related to the Qlik Deployment Framework (QDF). Providing best practices, libraries and utilities that facilitate the recommended setup and management of QlikView or Qlik Sense environments. An understanding of the Qlik platform is recommended before joining this group. Download QDF and documentation here: https://github.com/QlikDeploymentFramework/Qlik-Deployment-Framework/releases

Highlighted

QDF stopped workinng

Hi,

After updating Qlik Sense Server to version November 2018 QDF stopped working. Current version of QDF is 1.7.1. Before updating the server's version was September 2018 and QDF v.1.7.1. worked. I've tried to upgrade QDF to v.1.7.2. but this version messed all variables to shared folder 99. 

Which version of QDF is working properly with Qlik Sense Server November 2018?

Thank you,

Nikolai Atanasov

2 Replies
nzlysenko
New Contributor II

Re: QDF stopped workinng

Hi. Same issue. After updating QS Desktop to latest version QDF 1.7.2 doesn't work. It seems like new version has problem in sub declaration logic with include statement. Load script crashes during initializing sub in "99.Shared_Folders\3.Include\4.Sub\99.LoadAll.qvs".

I found temporaty fix for that. For each sub declaration file (1-14) in path "99.Shared_Folders\3.Include\4.Sub" just need to add some code in first line and then load must complete succesfullyCapture.PNG

Partner
Partner

Re: QDF stopped workinng

Consider performing an upgrade of your framework. There are adjustments made to QDF 1.7.2 since you posted this question that adress this issue.

Fetch the latest version from https://github.com/QlikDeploymentFramework/Qlik-Deployment-Framework

For future QDF questions I would recommend you posting them to the Qlik Deployment Framework Forum, a forum that the QDF main architect  Magnus Berg  @Magnus_Berg  and other fellow QDF users  are monitoring. 

Please ekskuse my Norglish and Swenglish typos.