Qlik Community

Qlik Education Discussions

Discussion Board for collaboration related to Qlik Education.

Not applicable

Authentication Required


I'm new to Qlik but have been trying to get webtickets working to view qvw files.  I've installed Qlik with the IIS option and the applications (QlikView, QvAjaxZfc, QVPlugin, Scripts) are all running under the default website.  Anonymous Authentication has been enabled for each running under IUSR Acct.  From one application (http://myapp.com), I want to be able to directly access Qlik via url.  I've followed the example here: An introduction to QlikView Security using Web Tickets, but when I use the ticket to access Qlik, I see a popup: Authentication Required - The server http://myapp.com requires a username and password.  Only if I enter a domain user account for the Qlik server am I able to see the QVW files, but it was my understanding that using webtickets would bypass this process.  I've tried using the QlikAdmin account for the Anonymous user account and I've tried granting security permissions to the directories where the qvw files are located.  Any help is appreciated.


3 Replies
Not applicable

Re: Authentication Required

Hi Nick,

I'm experiencing a very similar problem. Were you able to find a solution for this? Any advice is appreciated!



Not applicable

Re: Authentication Required

Hi Hugo,

I ended up needing to double check my IIS settings.  Only Anonymous authentication can be enabled.  When you have more than one when using web tickets, Qlik seems to get confused on not work properly.  One I made that change I didnt have the issue anymore.  Hope that helps...

Not applicable

Re: Authentication Required

Hey Nick,

Thanks for your feedback. I also had similar results. Making sure only Anonymous Authentication on the IIS settings was enabled also worked for me. Also, if I wanted to allow webticket users to see documents as authenticated users I had to set the Authentication for the QVS to "Allow Anonymous" (in QMC - System - Setup - QVS - Security settings). If anyone has similar problems, I hope that helps. Thanks again Nick.


Community Browser