Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
QlikWorld Online 2021, May 10-12: Our Free, Virtual, Global Event REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
dilara_askarova
Contributor II
Contributor II

NPRINTING number precision in Power Point Tables

I have a question about power point reports that use TABLE objects in NPRINTING 17.

I have an object in QlikView 12 app, and there is a filed that is formatted in NUMBER as Number with precision = 3.

Then I add this object as a Table to the Power Point report and check KEEP SOURCE FORMATTING, but this field is rounded to a nearest whole number instead of displaying 2 decimal points were applicable. 

When I select Fixed to 2 decimals, I see 2 decimals even on whole number and I don't want that.

What can I do to make sure that NPRINTING recognizes number precision selection?

 
 
 
 
Labels (2)
2 Solutions

Accepted Solutions
Frank_S
Support
Support

Hi @dilara_askarova 

Revised/Updated

Thank you,

I understand the problem now.

  • To resolve this, open the source QVW and switch from 'Mixed' to 'fixed to' format settings and set the output format you desire.
  • Save the QVW and reload the metadata before previewing your report again.

value.PNG

If this approach doesn't work, then you can use NPrinting designer by

  • select the 'value' you wish to format and deselect 'keep source format'
  • Type the format style in the format field that you wish to use ie: #,##0.00

One of these should work for you.

Kind regards...

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Frank_S
Support
Support

@dilara_askarova 

As I mentioned above,

If this approach doesn't work (fixed number format), then you can use NPrinting designer by

  • select the 'value' you wish to format and deselect 'keep source format'
  • Type the format style in the format field that you wish to use ie: #,##0.00

Revised with source QVW, source text file and copy of the exported NPrinting Sept. 2019 report attached so you can see exactly what I did.

Hope this helps...have a good weekend.

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

5 Replies
Frank_S
Support
Support

Hi @dilara_askarova 

I am a bit confused about your requirement. ie: it sounds like you first want to see 2 decimal points then you don't want to see 2 decimal points.

"...but this field is rounded to a nearest whole number
instead of displaying 2 decimal points were applicable. 

When I select Fixed to 2 decimals, I see 2 decimals even
on whole number and I don't want that"

To clarify your requirement:

  • Can you show an image of your QVW source chart so we can see the formatting?
  • Also should the actual results as an image of your current report output.
  • Can you provide a mockup image of your expected output results?

Thanks in advance.

 

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
dilara_askarova
Contributor II
Contributor II
Author

I want the chart to be displayed in the Nprinting report the same way it does when precision is set to 3 in QlikView document. 

I attached an image of the chart where precision is set to 3, and I want it to look the same on the NPrinting, but 2.54 is rounded to 3. But if I select Number Fixed = 1, then instead of 13 I see 13.00

Frank_S
Support
Support

Hi @dilara_askarova 

Revised/Updated

Thank you,

I understand the problem now.

  • To resolve this, open the source QVW and switch from 'Mixed' to 'fixed to' format settings and set the output format you desire.
  • Save the QVW and reload the metadata before previewing your report again.

value.PNG

If this approach doesn't work, then you can use NPrinting designer by

  • select the 'value' you wish to format and deselect 'keep source format'
  • Type the format style in the format field that you wish to use ie: #,##0.00

One of these should work for you.

Kind regards...

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

dilara_askarova
Contributor II
Contributor II
Author

That what I ended up doing, but now even whole number are displayed with decimal points, when using precision displays whole numbers without decimal points.

My question is how to make precision work in Nprinting report, or is it a current limitation on the system and I have to use number format fixed to number of digits after decimal point.

Frank_S
Support
Support

@dilara_askarova 

As I mentioned above,

If this approach doesn't work (fixed number format), then you can use NPrinting designer by

  • select the 'value' you wish to format and deselect 'keep source format'
  • Type the format style in the format field that you wish to use ie: #,##0.00

Revised with source QVW, source text file and copy of the exported NPrinting Sept. 2019 report attached so you can see exactly what I did.

Hope this helps...have a good weekend.

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post