Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

ldekoning
New Contributor II

NPrinting - Number format

Hi all,

I'm having an issue with number format when sending reports from an NPrinting Excel template. Basically, NPrinting is reversing the comma and point given up in Qlikview. But Excel treats them the way Qlikview does.

This means I need to specify format '#,##0' (with comma) to see format '#.##0' (with point) in Excel. This results in us not being able to use the "Use source formats" and we need to specify the format for every field we add in Nprinting. We have a large amount of data that we want to send through Nprinting so this will become a real pain.

Seeing as both Qlikview ánd Excel are treating the formats as expected, I am hoping that there is an Nprinting specific setting that I can use?

More specific: The following is an example of the case.

I Have a Qlikview document with expressions that are set up as a integer. In the "Number" tab the format is '#.##0' following from

SET ThousandSep=          '.';

SET DecimalSep=             ',';

Result of QV Expression in QV: 33.419.942

When I import these expressions into NPrinting with "Keep Source Formats" and export an example of a table or graph, my numbers are shown without a thousand separator and with decimal numbers. This decimal separator however is a comma (,). 

Now, If i change the Format in NPrinting into '#,##0'  (with a comma) and export to Excel I get the desired result.  The funny thing is that Excel than says that the format is "#.##0" (with a point).

Result of NPR Example with "Keep source formats":  33419923,66

Result of NPR Example with "#,##0" (Comma)           33.419.924         Excel "Format Cells"says format is "#.##0" (point)

Result of NPR Example with "#.##0" (point)               33419923,66       Excel "Format Cells"says format is "#,##0" (comma)

We are running Nprinting 16, Qlikview 11 and MS Excel 2013.

Is there a setting I can change in Nprinting? I have not been able to find anything as of yet, neither in settings nor on the forum.

4 Replies
ldekoning
New Contributor II

Re: NPrinting - Number format

I have now found now that it is indeed Nprinting who causes this problem.

in the PixelPerfect editor you can change the number format by clicking the drop down menu on a cell and then choose "Format String". If i type in

#,##0 (comma) there: It gives me the example: 123.456.789 (2 points)

#.##0 (point) there: it gives me the example: 123456789,000 (1 comma).

Now, I know we deal with numbers and points differently here than in the US, so I seems my question has changed to:

How can I alter how Nprinting deals with comma's and points? is there any localization setting i can change?

Thanx in advance

qlikhalmar
Contributor

Re: NPrinting - Number format

Hoi Lennard,

Did you resolve this problem?

I want to do the same in a cell of the reportfooter..

Halmar

tcarolus
New Contributor III

Re: NPrinting - Number format

The original post is from some time ago ... but maybe the following will help somebody else tackle similar problem when searching for a solution in this community.

Take a look at the Region settings of your NPrinting Services account on your NPrinting server. Changing these settings to the dutch (in my case) format solved a number format issue I had in a NPrinting - MS Word template.

Regards, Tamarah

leandro_job
New Contributor III

Re: NPrinting - Number format

It seems to me it's a bug of Qlikview. The follow link explains why this happens, but without a simple solution.

Comma separator in number format missing when export to html

The only fix i see is changing the regional settings of your server, but this is a change that you should do carefully, since could affect other aplications on your server.

Community Browser