Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

NPrinting Rabbitmq server is not connection

Hello,

I am having problems with my NPrinting system.  Specifically I cannot open a report or a connection.

When I look at the log files for the web.engine the message below appears:

RabbitMq server is not connected - trying diagnoser queue creation again in 10 seconds many times

I have followed the article support.qlik.com/articles/000044459 to reinstall rabbitmq.  It looks like rabbitmq is successfully running.

What else can I try?  

 

Thank You,

Michael

 

Labels (2)
2 Solutions

Accepted Solutions
Highlighted
Support
Support

It's possible that your NPrinting Server has been manually set to listen in plain text. Were any settings changed on your NP server to enable plain text?

Using an admin command prompt, run the following (use the correct sbin path in your environment) to diagnose.

C:\Program Files\NPrintingServer\rabbitmq_server-3.7.24\sbin>rabbitmq-diagnostics.bat status

You should see this in the 'listeners' section of the status output command: 

listeners.PNG

If you see extra lines including http, then it may be listening in plain text.

listening in plain text.png

In this case you would need to reverse any changes made to enable plain/clear text listening.

The other possibility is that you need to

  • Uninstall the NPrinting engine
  • Re-install the NPrinting engine (ensure the engine is the same version as the NP server)
  • In the NP web console, delete your NPrinting Engine entity, recreate it, then resend the certificates to solve the issue.
We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Highlighted
Partner
Partner

Hello,

Yes I did a complete reinstall.

 

So far so good.

 

Michael

 

View solution in original post

2 Replies
Highlighted
Support
Support

It's possible that your NPrinting Server has been manually set to listen in plain text. Were any settings changed on your NP server to enable plain text?

Using an admin command prompt, run the following (use the correct sbin path in your environment) to diagnose.

C:\Program Files\NPrintingServer\rabbitmq_server-3.7.24\sbin>rabbitmq-diagnostics.bat status

You should see this in the 'listeners' section of the status output command: 

listeners.PNG

If you see extra lines including http, then it may be listening in plain text.

listening in plain text.png

In this case you would need to reverse any changes made to enable plain/clear text listening.

The other possibility is that you need to

  • Uninstall the NPrinting engine
  • Re-install the NPrinting engine (ensure the engine is the same version as the NP server)
  • In the NP web console, delete your NPrinting Engine entity, recreate it, then resend the certificates to solve the issue.
We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Highlighted
Partner
Partner

Hello,

Yes I did a complete reinstall.

 

So far so good.

 

Michael

 

View solution in original post