Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

kakaderanjit53
Contributor III

Nprinting task getting failed

Hi Qlik Experts,

Kindly review the following Task Failed details of Nprinting Report,

Which was delivering successfully,before 16th May 2017 in the Qlik Hub and Via email as well.,But now there is some issue occurring for Report Generation and I unable to get the meaning of the task description details precisely,I am looking for the  resolution of the above problem.,PFB details for task Failed status:


1. Task Status


task np.png

2. Task Status Description Details:


task desc np.png



Thanks and Regards,

RANJIT KAKADE.

Tags (1)
8 Replies
Lech_Miszkiewicz
Honored Contributor III

Re: Nprinting task getting failed

Hi Ranjit

  • Was this task working before?
  • did you change your QVW recently and refreshed NPrinting connection?

Again - looks like something has changed in your QVW app. This is refering to your Entities in your template which now cannot be found in your connection metadata.

cheers

Lech

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
kakaderanjit53
Contributor III

Re: Nprinting task getting failed

Hi Lech,

Yes, I have been refreshed the NPrinting connection(i.e. reloaded metadata) for solving the same issue but

there is no problem in connection.

Thanks and regards,

RANJIT KAKADE.

Lech_Miszkiewicz
Honored Contributor III

Re: Nprinting task getting failed

Hi Ranjit,

What i ma saying is that in your template you have an object which was removed or modified in QlikVIew.

When you refresh connection in NPrinting it creates for each existing boject IDs. This is stored in Posgres DB (NPrinting repository)

When you build NPrinting report template it uses object ID's from connection and puts them also into repository DB as a Parent-Child reletionship

For Example:

XLS Template.

  •     You add table to your nprinting entities in template
    • this table has 4 columns (each of columns is a child to parent (table)

If you have changed anything in QLikVIew than you have to refresh your Entities in your template.

Look at this post where i explain how the hierarchy works in template builder works:

Tracing QlikView/Qlik Sense objects in NPrinting Reports

especialy look how entities are captured in the template_tree table


cheers

Lech

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
kakaderanjit53
Contributor III

Re: Nprinting task getting failed

Hello Lech,

I have idea about the above things very well but I have not Updated

template of Nprinting report and   even not  modified in QlikSense App!

Lech_Miszkiewicz
Honored Contributor III

Re: Nprinting task getting failed

Does Preview of your template work? Where you open template editor and hit Preview?

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
kakaderanjit53
Contributor III

Re: Nprinting task getting failed

No, I unable to get the preview of nprinting report template because of in the same report template contains total 2-sheets,in first sheet contains almost all image object and in the 2nd sheet contains dump table details which having more size.

Lech_Miszkiewicz
Honored Contributor III

Re: Nprinting task getting failed

I bet you Ranjit, that in this template you have an unavailable in current connection object - even if it is not used in your report, but is just added to your entities on left hand side of your template editor

I would troubleshoot it by building it again in new report and adding single objects one-by-one.

Also see whether you have some calculated dimensions in your objects in QlikSense which may not be supported.

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
kakaderanjit53
Contributor III

Re: Nprinting task getting failed

Hello Lech,

I have been created the same report twice but after that facing the same issue,and I have idea about the how add the objects in the report template and use of them  in the report same template.

Community Browser