Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
jxw007
Contributor II
Contributor II

Authenticating to S3

We recently switch servers from one EC2 instance to another to host Qlik Replicate. We using same EC2 Iam Role from previous server on new server  to connect Qlik Replicate to an S3 bucket but I am getting error below.

 

SYS-E-HTTPFAIL, Failed to connect to bucket'XXX',
SYS,GENERAL_EXCEPTION,Failed to connect to bucket 'XXX'.,Failed to stat S3 bucket 'XXX' AWS get bucket location failed: Access Denied

What could be the problem here?I will appreciate any guidance.

 

7 Replies
Dana_Baldwin
Support
Support

Hi @jxw007 ,

1. Do you get the same error if you go to the endpoint and click on "Test connection"?

2. Can you please:
- Log in to the bucket using the Replicate username and password using 3rd party tool
- Check that the replicate user has R/W permissions for the specific S3 bucket.

Please review this article.
Article:
https://community.qlik.com/t5/Official-Support-Articles/S3-Access-denied-to-bucket/ta-p/1745644

Thanks,

Dana

jxw007
Contributor II
Contributor II
Author

Hi Dana,

1.I get the error above by doing exactly that, that is using test connection in Qlik Replicate  console.

2. The Replicate user will be the ec2 instance server that host Qlik replicate right!The ec2 instance has permissions to access the bucket keep in mind that we migrated from one Qlik server to another and the new server using same IAM role as the old one. The old one worked just fine. 

SwathiPulagam
Support
Support

Hi @jxw007 ,

 

You have to verify the S3 access from the EC2 instance. Here is the reference link for detailed information:

 

https://aws.amazon.com/premiumsupport/knowledge-center/ec2-instance-access-s3-bucket/

 

Thanks,

Swathi

Kirag
Partner - Contributor
Partner - Contributor

Is this issue fixed ? We're getting same error.

SushilKumar
Support
Support

Hello team,

 

If our response has been helpful, please consider clicking "Accept as Solution". This will assist other users in easily finding the answer.

 

Regards,

Sushil Kumar

nareshkumar
Contributor III
Contributor III

Hi Dana, I am getting below error when we are testing the Databriks lake house :

  • Failed to check staging path 'tbdp-qlik-stage-dev/lios_delta_stg_poc'.
  • Failed to stat S3 object 'tbdp-qlik-stage-dev/lios_delta_stg_poc' AWS stat action failed: Invalid DNS Label found in URI host

whatever S3 credentials that we are using are working fine with S3 endpoint , but getting error in Databriks lake house  endpoint!!

john_wang
Support
Support

Hello @nareshkumar ,

This is more like a configuration issue. Let's focus on the error "Invalid DNS Label found in URI host". 

Would you please confirm if all the connection information are correct, and if proxy in use? If you can config a 64-bit ODBC DSN and use it to troubleshoot the connectivity issue then it's much easier. A helpful article: Databricks Lakehouse (Delta) Target connection not working.

Regards,

John.

 

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!