Skip to main content

Qlik Replicate

Discussion board for collaboration on Qlik Replicate.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
TaylorN
Contributor II
Contributor II

Delay in replication

I am replicating from Oracle 11g to Azure SQL DB (using redo logs). I have only just set this up within the last few days, but I have noticed very big gaps in the delay of processing. i.e. I can see changes in my source DB, but they aren't being picked up by Replicate for sometimes 1 hour or more.

1 Solution

Accepted Solutions
Ted_Manka
Support
Support

Hello Taylor,

 

I would recommend increasing your log levels for source capture, target apply and performance to trace level.  Then you should be able to see when the latency starts to increase and what is happening during that time or just before.  Also look to see if there are errors or 1-1 mode is taking over.

 

Thank you,

Ted Manka

View solution in original post

3 Replies
Ted_Manka
Support
Support

Hello Taylor,

 

I would recommend increasing your log levels for source capture, target apply and performance to trace level.  Then you should be able to see when the latency starts to increase and what is happening during that time or just before.  Also look to see if there are errors or 1-1 mode is taking over.

 

Thank you,

Ted Manka

TaylorN
Contributor II
Contributor II
Author

@Ted_Manka , thanks I have enabled verbose logging now to see how things go for a couple of hours.

I've also just noticed another issue where some records are not being brought across from the source DB. Some of the errors in the apply_exceptions table are updates with 0 rows affected because the original row was never inserted. 

The one with most of the errors, the source table has 102 318 367 rows and the target has 102 315 014 rows which is a bit of a concern.

Is there potentially a way to insert the missing data, if the update statement yields no effect?

Ted_Manka
Support
Support

Hello @TaylorN ,

 

If you open a new post for the new issue and tag me I will answer you there 😀

 

Thank you,

Ted Manka