Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 
bobhaffner
Contributor II
Contributor II

Exactly-Once in Replicate Kafka Target

Does Attunity Replicate support Exactly-Once when publishing to a Kafka topic?

ie "enable.idempotence","true"

1 Solution

Accepted Solutions
bobhaffner
Contributor II
Contributor II
Author

Turns out that Replicate does not support the property enable.idempotence after all

View solution in original post

4 Replies
Madhavi_Konda
Support
Support

Hi,

Replicate uses librdkafka APIs and these properties can be configured in the replicate console.
By default "enable.idempotence","false" but, as I said it is configurable and you can make it as "true"

The parameters listed in the below librdkafka URL are used by Replicate.
https://github.com/edenhill/librdkafka/blob/master/CONFIGURATION.md

Thanks,
Madhavi

bobhaffner
Contributor II
Contributor II
Author

Hi Madhavi,

I tried to set that property in rdkafkaProperties alongside my other properties, but I got the following error

SYS-E-HTTPFAIL, Failed to set rdkafka property 'enable.idempotence': No such configuration property: "enable.idempotence"..

 

What version of librdkafka  is Attunity 6.5.0.354 using?

Thanks

Bob

 

 

Madhavi_Konda
Support
Support

Hi Bob,
Good day!
You need to use rdkafkaTopicProperties internal parameter to enable this setting and replicate supporting librdkafka from the beginning of the Kafka target endpoint introduction in the replicate.

Thanks,
Madhavi

bobhaffner
Contributor II
Contributor II
Author

Turns out that Replicate does not support the property enable.idempotence after all