Skip to main content
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Failed to connect. SYS,GENERAL_EXCEPTION,Failed to connect,RetCode: SQL_ERROR SqlState: 08001 NativeError: 10061 Message: [Microsoft][

Hi all,

I'm using MS SQL SERVER is a source database and target database as well.(For Qlik replicate).

My Question is Here: Log  stream is stopped and due to below this error  and I'm unable to resume the log stream and end point connections also not succeeded.    

Creating Metadata Manager's utility components failed
Cannot create the source utility component
Failed while preparing stream component (Source database)
Failed to connect
RetCode: SQL_ERROR SqlState: 08001 NativeError: 10061 Message: [Microsoft][ODBC Driver 17 for SQL Server]TCP Provider: No connection could be made because the target machine actively refused it.

Labels (1)
2 Replies
Specialist III
Specialist III

READ the error message:

No connection could be made because the target machine actively refused it.

So the issue is not with Replicate, but with the database and its network configuration.

Note: The target machine in that message is from the ODBC layers perspective and means 'the target of the connection', which is here the source of the replication and not the target of the Replication. Again, READ the error message and its context such as

"Cannot create the source utility component"

Good luck.


Hello @ramu123 ,

Besides @Heinvandenheuvel comment, one of the efficient troubleshooting approaches is using ODBC DSN to test the connectivity issue as the problem is out of Replicate scope. Define a 64-bit DSN and do connection/query test by 3rd party 64-bit ODBC Test Tool, e.g. DataDirect ODBC Test Tool (Unicode) on Windows, or isql on Linux, probably you will get the same error. if the connectivity issues is fixed then Replicate could work as well.

Some helpful links for error 10061:


MS sql-server-error-10060-sql-server-error-10061

A pure TCP/IP connectivity test tool of Progress

Hops this helps.


Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!