Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

javier_garcia_g
New Contributor III

Cities poorly placed in a map.

Hello.

I am trying to show cities of Spain in a map. When I show the map, several cities are poorly placed, because it confused the name of spanish cities with others with same name in America.

mapa malo.png

I have the information in a table relationed with main table. This is correct.

lat-lon.png

How I can say to Qlik than my cities are from Spain? or How I can use latitude and longitude to placed them?

Thanks and regards.

1 Solution

Accepted Solutions
Ivan_Bozov
Valued Contributor

Re: Cities poorly placed in a map.

Looks like you cannot reference a calculated field as a geo data field. :/ At least in the version on the computer I am currently using - June 2017. However, if you have the field in the data file, it will work:

Capture.PNG

5 Replies
Ivan_Bozov
Valued Contributor

Re: Cities poorly placed in a map.

Hello!

If you are using the data manager to load the data, you can associate the field with your cities to a country: Changing field types‌ (check point 4 at the end of the page).

If you have longitude and latitude then either directly use the data manager which will create the geopoints automatically or use the script: Loading map data ‌‌

javier_garcia_g
New Contributor III

Re: Cities poorly placed in a map.

Hello Ivan.

I didn't know this. Thanks.

But the link of the documentation doesn't say how put 'Spain', only if is a city, county or country code. Where I can write that is 'Spain'?

And if I create a new column with the field 'Spain', I can't select this new field like GeoData, so Qlik don't recognize the cities like from Spain.

Thanks again and regards.

Ivan_Bozov
Valued Contributor

Re: Cities poorly placed in a map.

Looks like you cannot reference a calculated field as a geo data field. :/ At least in the version on the computer I am currently using - June 2017. However, if you have the field in the data file, it will work:

Capture.PNG

javier_garcia_g
New Contributor III

Re: Cities poorly placed in a map.

Great!

I did it. I include new column. Then I select the country in the column 'city'. Now the filter works.

Thanks.

I have other problem now. I should do the same with states of Spain. But in geodata I can't select 'state' in option.

But it is different problem.

If you know the solution of the last, I would be very very thankful hehe.

Thanks again and regards.


Ivan_Bozov
Valued Contributor

Re: Cities poorly placed in a map.

I think this option is for cities and countries only. If you want the states/regions, you should

     - either have longitude and latitude that point to the center of the region so you can create a point map

     - or KML file that will allow you to create an area map. Check this topic: KLM File for Spain

If this doesn't work, maybe open a new topic so that more people can join the discussion.