Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
LINKEDIN LIVE: Democratizing data to enhance customer-centricity. JULY 29TH REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
digichap28
Creator
Creator

Cant login from the server

Hey there! 

I'm testing some stuff and this time I tried to log in to the Qlikview accesspoint from the same server Qlik is deployed, but I couldnt. Do you know why this happens ? BTW... I can login from a remote client using the same credentials.

 

I get a 401 - unauthorized http error every time I submit the windows authentication form with my credentials.

The request header:

GET /qlikview HTTP/1.1
Host: myhost.com
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Connection: keep-alive
Upgrade-Insecure-Requests: 1
Authorization: NTLM TlRMTVNTUAADAAAAGAAYAH......

 

The response header:

HTTP/1.1 401 Unauthorized
Cache-Control: private
Content-Type: text/html; charset=utf-8
Server: Microsoft-IIS/10.0
WWW-Authenticate: NTLM
WWW-Authenticate: Negotiate
X-Powered-By: ASP.NET
Date: Sun, 14 Jun 2020 02:25:44 GMT
Content-Length: 6209

 

 

Thanks,

Diego

 

1 Solution

Accepted Solutions
digichap28
Creator
Creator
Author

Found the solution 😊 !! 

The LoopBack Check  - Please read about it here : https://marclsitinfrablog.wordpress.com/2013/01/03/windows-the-confusion-over-disableloopbackcheck-d...

 

There are 2 possible workarounds, but this one below is the recommended one.

 

  1. Click Start, click Run, type regedit, and then click OK.
  2. In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
  3. Right-click MSV1_0, point to
    New, and then click Multi-String Value.
  4. Type BackConnectionHostNames, and then press ENTER.
  5. Right-click BackConnectionHostNames, and then click Modify.
  6. In the Value data box, type the host name or the host names for the sites (ex. hostname.com) that are on the local computer, and then click
    OK.
  7. Exit Registry Editor, and then restart the server for this change to take effect.

 

For more details regarding the workarounds: https://support.microsoft.com/en-us/help/887993/users-experience-authentication-issues-when-they-acc...

 

I hope it can help others with the same issue 👍

 

Regards,

Diego

 

View solution in original post

4 Replies
digichap28
Creator
Creator
Author

I still can't login from the server. Anyone knows what can be happening ?

CJ29
Contributor
Contributor

Hi 

Can you provide more information. 

1. Were you able to login before?

2. Do you have a Qlikview license (User Cal or Doc Cal)?

3. Do you have access to the folder where .qvw file is saved?

4. How is section access implemented on .qvw file?

Please note you can have access to server for development but it does not imply automatic access to portal (access point) 

digichap28
Creator
Creator
Author

Hi CJ29

 

1. Were you able to login before?

This is the first time I try to login to the accesspoint using a browser installed on the QV Server. 

I can login from any other client machine.

2. Do you have a Qlikview license (User Cal or Doc Cal)?

I tried using different users with Named and Document.

3. Do you have access to the folder where .qvw file is saved?

I do. I can open them without any issues.

4. How is section access implemented on .qvw file?

There is no section access implemented on this app.

digichap28
Creator
Creator
Author

Found the solution 😊 !! 

The LoopBack Check  - Please read about it here : https://marclsitinfrablog.wordpress.com/2013/01/03/windows-the-confusion-over-disableloopbackcheck-d...

 

There are 2 possible workarounds, but this one below is the recommended one.

 

  1. Click Start, click Run, type regedit, and then click OK.
  2. In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
  3. Right-click MSV1_0, point to
    New, and then click Multi-String Value.
  4. Type BackConnectionHostNames, and then press ENTER.
  5. Right-click BackConnectionHostNames, and then click Modify.
  6. In the Value data box, type the host name or the host names for the sites (ex. hostname.com) that are on the local computer, and then click
    OK.
  7. Exit Registry Editor, and then restart the server for this change to take effect.

 

For more details regarding the workarounds: https://support.microsoft.com/en-us/help/887993/users-experience-authentication-issues-when-they-acc...

 

I hope it can help others with the same issue 👍

 

Regards,

Diego

 

View solution in original post