Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
DTL
Contributor II
Contributor II

ERROR in Governance Dashboard reload

Hello community !

After having fixed the 'AuditTimeStamp' issue, i could run the Governance Dashboard (V2.1.4) on my brand new QlikView server (May 2022 SR1) but then i get a message : [Error: Table 'QVWComplexity' not found] (See also the zipped full log in attachment).

Thanks in advance for your support.

Rgds

 

Labels (1)
1 Solution

Accepted Solutions
9 Replies
Mats_E
Contributor III
Contributor III

Hi

I get exactly the same error as you did. However using the steps in the article didnt help. Here is my scenario.

We have May 2022 SR1 aswell and governance dashboard 2.1.1. It has been working for a very long time without any issue. Then last night the reload job started to fail with this error.

Tried the steps mentioned in the article (though i didnt delete the qvd:s but rather moved them to another folder) and audit logging was already enabled. qvd:s was recreated when i ran the reload job after (except QVGD_QVWComplexity_2.1.1.qvd). As i have it backed up in another folder i can see that last modified date on QVGD_QVWComplexity_2.1.1.qvd was last successful execution.

Anyone have any new ideas on what i can try to resolve this.

I can mention that i have the same version of governance dashboard in another tst env and that one works fine.

sledison
Contributor II
Contributor II

I am having the same issue as Mats, I have removed all the QVDs and the dashboard still fails, it's not even creating the QVGD_QVWComplexity_2.1.1 qvd.

Shalini_Kannan
Support
Support

Hello,

This issue has been fixed in Qlikview 12.80 IR (QlikView - May 2023 IR ).

It is necessary to upgrade to a fixed release to resolve the problem.

Please try to upgrade and check.

Kind Regards
Shalini,
Qlik Support.

piekepotloed
Contributor II
Contributor II

Hi,

I 've the same problem. On August 8th the refresh of Governance Dashboard completed without any error. And the next day it drops this error: 

"Table 'QVWComplexity' not found

Left Join (sense_profile_score)
Load 
FileName,
ComplexitySheetCount as sense_profile_sheet_count,
ComplexitySheetObjectCount as sense_profile_sheet_object_count,
ComplexityObjectsNotCompatibleWithSenseList as sense_profile_objects_not_compatible_list,
ComplexitySheetObjectsPerSheet as sense_profile_objects_per_sheet,
ComplexityObjectsNotCompatibleWithSense as sense_profile_objects_not_compatible_with_sense,
 
ComplexitySheetCountActivated as sense_profile_sheet_count_activated,
ComplexitySheetObjectCountActivated as sense_profile_sheet_object_count_activated,
ComplexityObjectsNotCompatibleWithSenseListActivated as sense_profile_objects_not_compatible_list_activated,
ComplexitySheetObjectsPerSheetActivated as sense_profile_objects_per_sheet_activated,
ComplexityObjectsNotCompatibleWithSenseActivated as sense_profile_objects_not_compatible_with_sense_activated
Resident QVWComplexity
Where ComplexitySheetCount > 0"
 
Just installed Qlikview 12.80, but still the same problem. What can or should I do?
 
Kind regards,
Peter
Mats_E
Contributor III
Contributor III

Hi

I think (correct me if im wrong Shalini) that you also need Governance Dashboard 2.1.4 for it to work properly. Just upgrading is not enough. What version of Governance Dashboard are you using?

Mats_E
Contributor III
Contributor III

Btw i have not yet upgraded myself so i dont know if this resolves it for us yet either. I can mention though that i tested older version of Governance Dashboard today (2.0.5) and the reload job ran ok there. Dont think that this version produces the complexity qvd (has that logic). I will not use that older verstion though as it has other issues 

 

Regards

piekepotloed
Contributor II
Contributor II

In response to @Mats_E , version 2.1.4 was already running for months without problems.

I now commented two lines in the script: 

  1. Call sense_profile on the Run logic tab 
  2. drop fields QVWTables_FileTime,QVWFields_FileTime,QVWFieldsKey on the finalize tab

Now the rebuild runs smooth again, but can somebody tell me what the concequence is?

Mats_E
Contributor III
Contributor III

Ok i see

That is bad news. @Shalini_Kannan  can you take this further to the developers?

 

Cant tell you the concequence on the changes you did in the script. 

 

Regards Mats