Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
On Demand Webinar: See Why Thousands of QlikView Users Have Switched to Qlik Sense. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Qlikview doc slow to load first time from AccessPoint

We recently upgraded our server from version 9 to version 10 SR3 Windows 2008 and migrated to a much larger box (32 -> 128 GB). 

We've noticed that there is an unusual slowness (roughly 18 seconds) the first time a user opens any Qlikview document from the Access Point using IE Plug in.  The second document the user opens will open much faster (less than 2 seconds).

I've confirmed that the port 4747 is open within the Windows Firewall.

I've also read on the forum that one way to improve performance is to disable CPU hyperthreading.  We will be making this change over the weekend.

Does anyone else have any other suggestions?

Thanks in advance for your help!

Melissa

1 Solution

Accepted Solutions
Not applicable

We found out the issue.  It appears that users were being forced to tunnel even though port 4747 was open.  The reason is that in the config.xml file in c:\ProgramData\Qliktech\WebServer folder there was an incorrect value in the <LinkMachineName> property.  We had renamed our server, and it still had the old server name listed. 

The strange thing is that LinkMachineName value in the QEMC -> System -> Setup -> Qlikview Servers -> General tab is blank.

BTW - we noticed that were using the tunnel by looking at the QEMC -> Status -> QVS Statistics -> Performance tab and saw that the value under the DocSessions was equal to the value under the TunneledDocSessions.

Hope this helps.

Melissa

View solution in original post

10 Replies
Miguel_Angel_Baeyens

Hi Melissa,

Make sure the document is preloaded. This setting is in the QEMC, Documents, and clicking on the document you want to reload. This puts a copy of the document in memory after reloading, so the first access is faster because the document is already loaded.

Make as well the users to open the document in a "landing page" instead of a sheet with lots of objects. The sheet will not be rendered until all the objects are calculated, and depending on your dataset that may take some time. A landing sheet may be a blank sheet with the company logo or something very simple.

With these two settings your document should sppear as fast as the network allows it.

Hope that helps.

Miguel

danielrozental
Master II
Master II

We're having a similar issue and we're opening a blank application with no data, yet we have response times that range from 10 to 40 secs just to open it.

IAMDV
Luminary
Luminary

Hi Miguel,

This are any standard practice for preloaded document setting? I mean if I enable this setting for all the documents then I'm assuming that loads of memory is used even when the document is not used. I understand we can enable this to mission critical applications but is there any best practice?

Also, where do I find the setting to set the "landing page"? Because when I'm using Ajax ZFC in QV 10 SR4 and if the user closes the document in random page then my next user is not starting from the "start page" instead he is starting from the session left by previous user. Any helps on this is really appreciated.

Cheers - DV

Not applicable

We found out the issue.  It appears that users were being forced to tunnel even though port 4747 was open.  The reason is that in the config.xml file in c:\ProgramData\Qliktech\WebServer folder there was an incorrect value in the <LinkMachineName> property.  We had renamed our server, and it still had the old server name listed. 

The strange thing is that LinkMachineName value in the QEMC -> System -> Setup -> Qlikview Servers -> General tab is blank.

BTW - we noticed that were using the tunnel by looking at the QEMC -> Status -> QVS Statistics -> Performance tab and saw that the value under the DocSessions was equal to the value under the TunneledDocSessions.

Hope this helps.

Melissa

View solution in original post

IAMDV
Luminary
Luminary

Hi Melissa,

Thanks for sharing. This is very useful. Especially on how to identified the TunneledDocSession.

Any help on my earlier questions is really appreciated.

Thanks - DV

Miguel_Angel_Baeyens

Hi DV,

Depending on the hardware, having a lot of huge documents, preloading may affect to its performance. Anyway, the documents will eventually be loaded into memory, so if the data is already in memory, users will have their first access faster.

In the Settings menu, Document Properties, Opening, you can set how the document will look like in the Accesspoint thumbnail. The option by default is the opening page, that is, the page that was open when the document was saved last, but you can change that. Is always a good idea that the dociument has an almost empty sheet (no charts at least, but some logos and welcome screen instead) as the first sheet, develop as you need, change to that, and save the document. This way the document will show up faster, because there is no charts or other objects to calculate.

Hope that makes sense.

Miguel

IAMDV
Luminary
Luminary

Thanks Miguel. Very helpful and I agree that preloading is not recommended for all the documents but it will be useful in most of the scenarios.

Thanks again for your time & help.

Cheers - DV

brindlogcool
Creator III
Creator III

Hi DV,

Do you able to find solution for the landing page issue. Correct me if i am wrong. Consider the QVW file test.QVW file has three sheets and it has been set as the first sheet defaulted(Using the Trigger) when the user opens the Document in the Accesspoint. If user opens the doc at the Access Point in Ajax ZFC and closes it  at Sheet 3. So the next user while opening the doc (different user so different session) at Accesspoint is landing in to Sheet even there is a trigger to open with Sheet 1 as default?  I was not able to replicate this issue.

elkis1006
Contributor
Contributor

Hi Melissa,

My English is bad, sorry. XD

I want to know if this solution apply to QVS   (V.11) too.

Thanks and Regards.