Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
DickyMohanty
Contributor
Contributor

User Document QVW - getting automatically rollback/overwritten/recreated - Confusing?

Hi Team,

Need a help here in finding out what Process causing a particular QVW getting overwritten automatically, or Rolled back to old data or getting recreated automatically (when its not present at all).

We have certain Source QVWs, which are reloaded and distributed into User Doc folder. Ex - XYZ_1.qvw, XYZ_2.qvw, XYZ_3.qvw.

Suddenly one particular day, one of the User Doc qvw, lets say XYZ_2.qvw, seemed to be showing old date data. Though some issues in .Meta or .Shared file. so deleted them and reloaded the Job to recreate them.

But that keeps on coming like this - QVW showing one particular Old Date data, QVW is getting overwrtitten automatically (where Source Doc has not reloaded and no other Jobs are running at time), even if the User Doc is deleted and not present too - from somewhere the file is auto-created and started showing up magically with old data.

Tried lot of steps already - 

  • Checked Events Log. Not much info.
  • Ran Process Monitor. Its running very long time though. Could not understand anything there
  • Deleted and recreated the QVW, .Meta, .Shared file
  • Deleted and Recreated the Task again in QMC.
  • Antivirus Exclusions are already in Place
  • Submitted ticket to Qlik - but they keep on asking about Process Monitor logs, which are time consuming.
  • Sometimes opening the QVW says - The Process cannot access the file because it is being used by another process.

Only one finding today - if I tried distributing the QVW in a different name, Ex - XYZ_New_2.qvw, then the file remains correct and its not rolledback or overwritten or recreated. 

So understanding is that - there is no issues with the Source/base QVW or Script or the QMC task. That particular name/Nomenclature has been stored or locked out in some Process, which we need to find and Kill.

Please help, how to find the process which is causing the issue. Any help will be greatly appreciated.

Labels (1)
1 Reply
Brett_Bleess
Support (Former)
Support (Former)

Dicky, the only thing that comes to mind given what you explained, is something is actually corrupted in memory on the QlikView server machine, have you stopped the QVS service and made sure the process went down completely in Windows Task Manager and then restarted the QVS service?  Best I have on this one for you, let me know if it makes any sense or not.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.