Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
fmcrashid
Contributor II
Contributor II

what is max number of sessions a document can have?

what is max number of sessions a document can have?

In QMC I see one of our dashboard showing 259 users. Is it bad? in reality dont think it is correct. Usually we have max session around 50. 

 

Labels (2)
1 Solution

Accepted Solutions
Brett_Bleess
Support (Former)
Support (Former)

Rashid, if you think you have something odd going on with the session counts, use the QMC\Status\QVS Statistics are to see if a user or two have a lot of sessions going in the same application or not, that is generally what you should see if there is something happening.  If you do notice that, we'll have to figure out what is going on in the environment but generally only see this when the server gets overloaded etc.  

Just FYI as well, the Max Concurrent sessions set on the server by default is 5000, and each of those represents a user in an application, not sure if your servers would be able to handle that many or not, but that setting is on the QVS resource settings in the QMC\System\Setup on the Performance tab.  Those can be used to better manage the environment if need be.  About the best I have in addition to what Sonja wrote up for you.

When the issue occurs, check the QVS Event log as well and see if you are seeing tickets being generated over and over for the same user, that is the other symptom on this one...  Should be one being created about every 30 seconds or so from what I recall in that case.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.

View solution in original post

2 Replies
Sonja_Bauernfeind
Digital Support
Digital Support

There isn't really a "max session" amount that a document can have. At least not one value that fits all environments. 

The value is entirely dependent on the environment (how much load the server can handle) and the document (how complex it is).

If you are seeing performance impact as the sessions increase, or believe that the session count is incorrect, our knowledge base might be able to assist further. 

 

Don't forget to Like posts and use the "Accept as Solution" button on content that answered your question! Thanks 🙂
Brett_Bleess
Support (Former)
Support (Former)

Rashid, if you think you have something odd going on with the session counts, use the QMC\Status\QVS Statistics are to see if a user or two have a lot of sessions going in the same application or not, that is generally what you should see if there is something happening.  If you do notice that, we'll have to figure out what is going on in the environment but generally only see this when the server gets overloaded etc.  

Just FYI as well, the Max Concurrent sessions set on the server by default is 5000, and each of those represents a user in an application, not sure if your servers would be able to handle that many or not, but that setting is on the QVS resource settings in the QMC\System\Setup on the Performance tab.  Those can be used to better manage the environment if need be.  About the best I have in addition to what Sonja wrote up for you.

When the issue occurs, check the QVS Event log as well and see if you are seeing tickets being generated over and over for the same user, that is the other symptom on this one...  Should be one being created about every 30 seconds or so from what I recall in that case.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.

View solution in original post