Skip to main content
Announcements
July 15, NEW Customer Portal: Initial launch will improve how you submit Support Cases. IMPORTANT DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Chart expression works in 32 bit mode, but out of memory in 64 bit

I have run into a very strange issue which appears to be a bug in the x64 (64 bit) version of QlikView.

I am running the latest release 9.00.7320.0409 (i.e. version 9 SR2).

I have a chart expression which works fine in the 32 bit version, but which generates "Allocated memory exceeded" errors in the 64 bit version. I have reproduced the problem on Vista and Windows Server 2003 (both x64 version), and to be safe, re-ported to a different 32 bit computer without issue.

For whatever reason, the underlying row count on my selected fact table records cannot exceed 1048576 records (i.e. 1 MB rows). If it's under, then it computes fine. If it goes over, I get the "Allocated memory exceeded" error.

I am running a trial version (both 32 bit and 64 bit) - we are performing a full evaluation of the product. So far so good till I hit this brick wall. Could there be a hidden limit in the x64 trial version?

Any suggestions would be greatly appreciated.

3 Replies
Anonymous
Not applicable
Author

Hi,

Could you post some more details on the chart, such as Dimensions and Expressions?

Or better yet, perhaps a reduced copy of the document, or an example document with the same behavior?

Not applicable
Author

I attempted to create a reduced version of the document which has since revealed a possible explanation. I'm still working away at the problem, but from what I can tell the issue is related to my hierarchies.

To explain further, I use the hierarchy command during my load to build hierarchies. I also generate a PATH field for use in the List Box (as TreeView) However, above the leaf nodes there is no direct link to my fact table.

The reason why I believe the two are related is that while I was attempting to create a reduced version of my QVD file, I noticed that things appeared to magically start working. In actual fact, other problems were introduced, but I could see that a number of paths (i.e. paths without a leaf node), were eliminated.

I'm proceeding to create denormalized versions of my hierarchy tables (I use 3 in total) which all join to my FACT table. From there I should either have a fix to my problem, or possibly be able to reduce it to a size that can be sent on this forum.

As an aside, I attempted to upload my original file (275 MB), and not surprisingly the upload failed. Worst comes to worst, I may just upload the file to a different web site and link there.

Either way I'll keep the forum abreast of my situation.

Thanks very much in the meantime!

Not applicable
Author

I have isolated the problem as much as I can, and have attached (zipped) a QV file reproducing the problem.

Here is what I've done and where I'm at:

1. I discovered that I could eliminated the "exceeded allocated memory" error but removing any ORG units that are not referenced by any of my fact records. However, this has effectively shifted the problem to incorrect values calculated in my chart expressions. These problems go away on a smaller selection, so I have reason to believe that the memory issue and incorrect calculations are related.

2. I have reduced the data set to as small as possible (any smaller and the problem goes away).

3. The problem is that the Chart expression is not calculating the number of aggregations correctly. Based on the logic of the chart expression, and how I am aggregating, the total value cannot exceed the number of distinct values for "ORG1_MemberName7". In the 32 bit version of QV, this always holds true, in the 64 bit version this number goes much higher, unless I reduced the number of underlying fact records that are selected.

Here are the dimensions:

SG1_QShortDesc2, SG1_QShortDesc3

Here is the expression:

count($(NationalOrgSet) total <SG1_QShortDesc2, SG1_QShortDesc3>

aggr(

avg($(NationalOrgSet) FT_FormulaValue),

ORG1_MemberName7, SG1_QShortDesc2, SG1_QShortDesc3

)

)



So, I believe the bug is related to: 64-bit with aggregation functions contained within an aggregate function using the "total" keyword with the pivot dimensions.

Any help is much appreciated. Smile