Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join “Do More With Qlik” with Mike Tarallo to get a first-hand look at the New Authoring Experience, June 29th: REGISTER HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Conditional View Not Working

In a list box I put this as the expression.  The count of lid will always be more than 1 but the listbox never hides.  Any ideas?

if(Count (lid) >1,1,0)

1 Solution

Accepted Solutions
swuehl
MVP
MVP

Really should work...

Have you tried hiding another object?

And please check

Settings - Document Properties - Security - Show all sheets and objects

is NOT enabled.

View solution in original post

10 Replies
swuehl
MVP
MVP

You are talking about the conditional SHOW in layout tab, right?

If your condition is true, it will show the object, not hide...

Not applicable
Author

Yeah I am talking about that show in the layout tab.  So I changed it to < and it still did not work.

swuehl
MVP
MVP

But if you put 0 or 1 in the expression, it will hide resp. show?

Not applicable
Author

Sorry I am not sure what you mean.  If I put 0 or one where?  I can't get it to hide ever.  It always shows.

stabben23
Master
Master

Hi, Switch position on the 1 and 0 like: if(Count (lid) >1,0,1) or use sum(if(lid)>=1,0,1)) 0 is for hide 1 to show the object.

swuehl
MVP
MVP

ListBoxShow.png

I am talking about this expresssion. It's just working fine at my place.

If you say, the count is always larger than 1, your condition is like a constant, isn't it? so I assume you do this also for testing?

If I replace

if(count(lid)>1,1,0)

with 1 resp. 0, it's just to test that the Listbox will show resp hide (Or use if(1,1,0) resp. if(0,1,0)).

(And use apply button to apply new conditions, if you hide a listbox and click ok, you need to open sheet properties - objects to be able to enter properties again).

Please check in a textbox, that count(lid) really returns the value you expect.

Not applicable
Author

Hi,

just go to list box poperties and in layout tab, you will see the show section there you can choose to show always or conditional.

Click on conditional radio button and put 0 there. Just apply and you will see that your list box hides. To show it again put 1 there and click on apply, your list box will appear.

that way you can show and hide.

Now, you just need to put a condiiton here which returns 1 and 0 on the desired condiitons.

...

Ashutosh

Not applicable
Author

http://screencast.com/t/racxl5Rd4hj  I put a 0 in the box but it still won't hide.  This is the listbox school id in the screenshot. 

swuehl
MVP
MVP

Really should work...

Have you tried hiding another object?

And please check

Settings - Document Properties - Security - Show all sheets and objects

is NOT enabled.