Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
kris_vliegen
Partner
Partner

Export to semicolumn csv in accesspoint

Hi all,

I would like to export a straight table to a semicolumn separated csv-file in accesspoint.

If possible I would like to do this via a button.

If I use the right mouse button and export I get a comma separated csv.

Who can help me?

regards,

Kris

18 Replies
olivierrobin
Specialist III
Specialist III

hello

if you right click to export, you can choose between file formats an delimiters

.csv

.txt

and commas, semi-colons, tabulations ....

olivierrobin
Specialist III
Specialist III

and in the same manner, if you choose export action in a button, you can configure several options when choosing file as destination of the export

kris_vliegen
Partner
Partner
Author

Do you mean in the access point?

If I right click on the straight table and choose ExportExport.png

I have to click "Press here"

Export_2.png

And than Qlikview downloads a csv-file.

export_3.png

But this file is comma separated. not Semicolon separated.

olivierrobin
Specialist III
Specialist III

oups

i tried in desktop not in browser

kris_vliegen
Partner
Partner
Author

If I choose the export action in a button.

It opens a new tab with the data.

And I've selecte the SKV-filetype but it creates a comma-separated table.

In the browser I can't find a save-button and I can't find the saved file.

marcus_sommer
MVP & Luminary
MVP & Luminary

AFAIK the used delimiter is related to the regional settings from the OS. Therefore a change might be work but be carefully because this are global settings and it could have various side-effects (by us with german settings the delimiter is the semi-colon).

Another possibility might be that this could be overwritten within the settings.ini but I don't know which setting must be added or changed. You could try a search for it and/or playing with various settings from the easter egg (within the desktop client) and then looking in the local settings.ini - but it's an ugly trial & error game ...

Therefore it might be easier to change your afterwards processing to accept commas and/or to detect the delimiter and to branch in the appropriate data-extracting.

- Marcus

kris_vliegen
Partner
Partner
Author

Hi All,

I've created one string where I insert all the values seperated with a ";".

This is all working fine but if there is one value with a comma in he put a double quotes in the beginning and the end of the record.

Is there a way I can disable this?

Regards,

Kris

marcus_sommer
MVP & Luminary
MVP & Luminary

You could try it with no quotes within the file-format like: (txt, delimiter is ';', no quotes)

- Marcus

kris_vliegen
Partner
Partner
Author

Hi Marcus,

this you can do when you do a store statement in the script.

The problem I have is that the user is creating a csv in the access-point.

regards,

Kris