Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Filtering zero values

Hi,

In the chart I have following expression:

Sum({$<DatCen={">=$(vStartDate) <=$(vEndDate)"}, [Entry Type]={1}>}-Quantity)

My goal is to filter data to show only zero values or values which are <=vInput.

Suppress zero values in Presentation tab is not an option in this case, My opinion is that I can solve this through calculated dimension I Was try with:

=If(Aggr(Rank(Sum({$<DatCen={">=$(vStartDate) <=$(vEndDate)"}, [Entry Type]={1}>}-Quantity)<=vInput), Sum({$<DatCen={">=$(vStartDate) <=$(vEndDate)"}, [Entry Type]={1}>}-Quantity))<=vInput, Sifra, Null())

but result is error. Any ideas?

TIA, Igor

1 Solution

Accepted Solutions
Kush
MVP
MVP

Make sure that vInput has numerical value. it will be helpful if you can share the sample to look at

View solution in original post

4 Replies
Kush
MVP
MVP

try below calculated dimension

aggr(if(Sum({$<DatCen={">=$(vStartDate) <=$(vEndDate)"}, [Entry Type]={1}>}-Quantity)<=$(vInput),

Sifra,null()),Sifra)

check suppress when value i NULL option on calculated dimension

Expression will be like below

Sum({$<DatCen={">=$(vStartDate) <=$(vEndDate)"}, [Entry Type]={1}>}-Quantity)

Not applicable
Author

Thx for your reply, but with yours calculated dimensions all records are shown as null()

Kush
MVP
MVP

Make sure that vInput has numerical value. it will be helpful if you can share the sample to look at

View solution in original post

Not applicable
Author

You are correct. Thank you very much. Now I will have peaceful weekend.